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Beginning Computer
Graphics Users

Experienced Computer
Graphics Users

Those Who Don't
Read Manuals

After you've read What's New, reviewed the Table of Contents,
and installed DeluxePaint IV, use the manual in whatever way
suits you and your work. Follow our Guided Tour or strike off on
your own. You can always consult Reference if you need help or
want more information. Here are a few approaches you can take
to learn DeluxePaint IV, depending on your knowledge of com-
puter graphics programs.

Work through Getting Started and the Guided Tour—in order
and in detail. These chapters describe the fundamentals of the
program and introduce some advanced techniques. You'll start
creating with DeluxePaint IV right away and learn about its
more complex functions as you go along. After you've worked
through the Guided Tour, move on to what interests you. We
highly recommend Chapter 4, Painting Tutorials. Keep the
manual close by so you can consult Reference to learn more
about other program features when you‘re ready.

If you're already familiar with DeluxePaint III, quickly scan
What'’s New, for new information. You'll find an introduction to
some of the unique paint features of DeluxePaint IV there. Move
on whenever you're ready. Use Chapters 4-8 and the Appen-
dixes to learn more about powerful program features like color
mixing, the LightTable, stencils, and animation.

If you don’t read manuals as a rule, we still hope that you'll
read Getting Started. Keep this manual nearby, so you can
consult it when you need to.
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Editing a Startup
Sequence

Using a Floppy Drive

.
o

10.

11.

Note: If you are using Amiga DOS 2.0, you do not need to
run ColorText because it is already supported by your
system.

Drag only the DeluxePaint Program and Color Text icons to
the new drawer. Do not drag Install DPaint or Preferences onto
your hard drive as they are not needed to run DeluxePaint.

When the copy is complete, eject the Program disk and insert
the DeluxePaint Artl disk.

Double-click the Artl disk icon to view the contents of the
disk. Click the Picture drawer to select it. Then press and
hold down the Shift key and click the Brush drawer to select
it. Repeat this procedure with the following drawers: Colors,
Move, Karafonts, and Empty. Drag all the drawers to the
DPaint IV drawer on your hard drive.

When the copy is complete, eject the Artl disk and insert the
Art2 disk.

. Select and drag the drawer icons into the DeluxePaint

drawer as you did the Artl disk icons in step 8.

You now have copies of the DeluxePaint Program and both Art
disks on your hard disk.

1. Start up the CLI or Shell by double-clicking on the
appropriate icon (probably in your System drawer).

2. Follow the instructions in your Amiga User’s Guide to enter
and edit the start-up sequence.

3. Type assign DPaintlV: hard drive name:drawer
name into your start-up sequence.

For example, if you hard drive is named speedy and your
drawer is named DPaintIV, you would type:

assign DPaintIV: speedy:DpaintIV

4. Exit the start-up sequence and return to the Workbench.

>

16

Turn on your computer and monitor. (Amiga 1000 users, start
by inserting the Kickstart disk [1.3 or later] in the internal
drive.) When the request for the Workbench disk appears on
the screen, insert your working copy of DeluxePaint.

Double-click the DeluxePaint disk icon to open the disk
window.

Chapter 1 DeluxePaint 1V
















35;4
(0] | T [ [l | |

=

-
- s rS
g
AR 1=
e JJits

=R

&
=
<

SY
5
=



Chapter 2: Guided Tour (1)

Painting Screen 23

Title Bar 24

Menus 24

Palette 25
Color Indicator 25

Painting with the Mouse 26
Picking Colors from the Screen

Toolbox 28
Built-in Brushes 28
The Painting Tools 29
Anything Can Be a Brush 34
Toolbox Summary 38

Saving Your Work 38

22 Chapter 2

27

DeluxePaint IV

0000000000000 0000000000OC0OCOCCOCGROCOKOINONONONOCTS
















REMINDER

Picking Colors
from the Screen

KEyBOARD EQIVALENTS

Follow this simple rule: use the left mouse button for painting
with the foreground color, and the right button for painting with
the background color. This parallels the rule we noted above for
selecting colors from the Palette: select the foreground color by
clicking with the left button and the background color by click-
ing with the right button.,

So far you’ve been selecting your colors by clicking them in the
Palette. DeluxePaint also lets you select colors directly from the
screen. This is useful if you are working on fine details, or if you
are working with many shades of the same basic color. For ex-
ample, if you are painting a rose using eight different shades of
red, it might be easier to pick the color you need directly from
the screen rather than choosing it from the Palette.

» Click anywhere in the Color Indicator and move the pointer
back to the screen. The pointer changes to an eye dropper
cursor. Point to a color on the screen and click either the left
or the right mouse button to select a new foreground or back-
ground color respectively.

An even easier way to select a color from the screen is to use a
keyboard equivalent. Keyboard equivalents are shortcuts for doing
something you would otherwise do with the mouse. In this case,
it might be tiresome to click the Color Indicator every time you
wanted the eye dropper to choose a color from the picture. The
shortcut is to press the comma (,) key to get the eye dropper, and
then click a color. By using the keyboard equivalent, you never
have to move the cursor from your picture.

Practice painting with the mouse for a while and try selecting
colors from the screen. Remember, you can always click UNDO
to reverse your last action, or CLR to clear the screen and start
afresh. As soon as you're ready, move on to the next section,
where we will be examining DeluxePaint’s collection of brushes
and tools.
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The Painting Tools

IT’s a Rute

[]

In the next section we will be looking at the other drawing tools
and seeing how they interact with the brushes.

The ten icons below the built-in brushes (in two columns of five)
control the painting tools. Because any brush can operate with
any given painting tool, you have a wide variety of combinations
at your fingertips.

To select a painting tool, click on it.

We'll describe the tools in order, moving left to right and top to
bottom:

The Dotted Freehand tool allows fast freehand drawing. No mat-
ter how fast you draw, this tool keeps up with you, making it
ideal for sketching out a shape quickly before concentrating on
the intricate details. Note, however, that the faster you go, the
bigger the gaps in your drawing. Once you have roughed out a
shape, you can refine your image using some of the other tools
at your disposal. Try drawing with it using some of the other
brushes to get a feeling for how it works.

The Continuous Freehand /Freehand Shape tool paints unbroken
lines, but it doesn’t keep up with you if you draw fast. It's better
suited than the Dotted Freehand tool for slower, more precise
drawing.

» Try the Continuous Freehand tool with different brushes and
see how brush size affects speed. The smaller the brush, the
better it is at keeping up with your painting strokes.

Notice that the Continuous Freehand tool icon has a diagonal
line running from its top right to its bottom left corner. This is
because it is actually two tools in one — the top left one draws
unbroken freehand lines, while the one at bottom right creates
freehand shapes filled with the current foreground or back-
ground color.

To create a filled shape:

» Click the lower right part of the Continuous Freehand tool
and paint any shape.

When you release the mouse button, the shape you painted is
filled with either the foreground or background color, depending
on which mouse button you pressed when you painted the
shape. If you release the mouse button before you close the
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The File edit box is where you enter the name of your picture the
first time you save it.

If you want to save your current creation, this is your chance to
do so.

» Inserta blank, formatted disk in any drive, for example, DF1.

» Click the Disks button. The name of the drive that contains
the blank disk should appear in the window (<DEV> DF1:).

» Click on the disk name in the window. In our example DF1:
appears in the Drawer edit box.

» Click anywhere in the File edit box and type in a name for
your new file.

» Click Save.

The disk drive will spin for a few moments; when the red light
goes out, the file is saved.

The next time you save this file (it's a good idea to save work in
progress every 15 minutes or so, so that a power failure or other
breakdown doesn’t turn hours of work into a bitter memory), the
Save Requester uses this same information, which means you
won’t need to type anything more unless you want to change the
file name. You might want to do this to save it under another
name, if you want to save each version as a separate file. In that
case, you would click the File edit box as before, backspace over
the old file name (or over those parts you wish to change) and
type in the new name. Or you could just keep adding suffixes,
such as 1, 2, 3, etc., to signify succeeding versions.

You can specify drawer names in the same way: click in the
Drawer edit box, backspace over the old name, and type in the
new name. You can open any drawer already on the disk, but
you cannot create one from the Save Requester. See your Amiga
User Guide for information on creating new drawers.

For more information on all the options available from the l.oad
and Save requesters, see Reference.

Right now you might want to take a break. When you're ready, move on

to the next chapter, Guided Tour (2), where you'll learn how to modify
tools and work with many other powerful features of DeluxePaint.
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The Background
Color Is Transparent

The Corner Color
Is Transparent

Changing the
Transparent Color

Now you should have a black screen, because black is your
background color, with several colors scrawled over it (see
Figure 3.1).

p Click the Brush Selector icon, and move the cross hair to the
painting area.

» Select a rectangular area that contains some black.

When you release the mouse button, the black areas of your
brush are transparent because black was the background color
when you selected the brush. Move the brush around to confirm
this: the painting shows through the areas where there used to be
black. Any parts of the brush that consisted of background color
when the brush was first created remain transparent, even after
you change background colors. But if you want to change the
transparent color, you can do that, too. We’ll show you how in a
moment.

Now let’s see what happens when you select an area with all
corners the same color.

» Move the pointer to the far right of the Title Bar, and press the
right mouse button.

The Menu Bar appears and the Prefs menu extends down.

» Choose the AutoTransp option. Display the menu a second
time to confirm that AutoTransp now has an check (V) beside
it. This means that it’s turned on.

» Double-click the Brush Selector icon to activate the polygonal
brush selector.

B Select an area of any shape. Make sure that you always click
on the same color, but not on black (since this is the back-
ground color and won't illustrate what we want to see).

This creates a brush in which the color you clicked on is trans-
parent because AutoTransp is turned on, and all corners of your
brush are the same color.

We used the polygonal Brush Selector for our example, but the
AutoTransp option is especially useful for picking up a shape
from any solid background without having to change the current
background color.

You can change which color in your brush is transparent by
choosing a new background color and then choosing Brush>
Change Transparency from the Color menu. Let’s try a quick
example.
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A Brush Isa
Little Picture

» Click the Brush Selector and select a rectangular area that
contains some of the current background color so that your
brush has some transparent areas.

» Choose a new background color by clicking on a color in the
Palette with the right mouse button.

Notice that simply changing the current background color does
not change the transparent areas of your brush. You accomplish
that with the next command.

» Choose Brush>Change Transparency from the Color menu.

The transparent areas of your brush change from the areas of the
original background color to the areas of the current background
color. You can do this as many times as you like to change trans-
parent areas.

From the Brush menu you can treat brushes just like full pic-
tures. You can Load and Save them just as you can other pic-
tures. When you load a saved brush, it comes equipped with its
own palette and ranges, the ones that were in effect when the
brush was first saved. If the current picture is using a palette dif-
ferent from that of the newly-loaded brush, you can change the
current palette to the brush’s palette by selecting Palette>Use
Brush Palette from the Color menu. On the other hand, if you
want to use the newly-loaded brush with the current palette,
select Brush>Remap from the Color menu.

Other options in the Brush and Color menus let you resize,
reshape, and recolor brushes in various ways.

Your DeluxePaint Art disk contains a number of saved brushes.
Let’s load one now just to see how it works:

» Insert the Art disk into any drive. Select Load from the Brush
menu. Click <VOL> Art: in the Save Brush requester.

» Click <DIR> Brush. The Drawer edit box reads Art:Brush.
Double-click Bobsled and the file will load automatically.

» The Bobsled brush is attached to your cursor, but its colors
are not correct.

» Choose Palette>Use Brush Palette from the Color menu.
Select the Continuous Freehand tool and paint with the
brush.
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Additional Features

Handle

Perspective

Do you see why this brush is called Bobsled? Feel free to experi-
ment with some of the saved brushes. Select Palette>Use Brush
Palette whenever you load a brush to ensure that you are seeing
it as it was when it was saved.

% If you would like to see color cycling in action, load the brush
called Fireworks.

1. Select MultiCycle from the Prefs menu.

o

Select Cycle from the Mode menu.

3. Select Palette>Use Brush Palette and then press the Tab key
before you start drawing with it.

“Fireworks” comes complete with color cycling information,
and is a spectacular example of the power of this feature. See
Tutorial Two: Working With Ranges in the next chapter for more
demonstrations of color cycling.

The following are some additional features relating to custom
brushes.

This feature, which is available from the Brush menu, allows you
to specify where the cursor will sit in your custom brush. In the
default setting the cursor sits at the center of the custom brush.
When you select Handle>Corner, the brush handle moves to the
lower right-hand corner of the brush. Each successive choice of
the Corner option moves the handle to a different corner.

Once you have selected Corner, the brush handle attaches itself
to the ending corner when you enclose a brush. For example, if
you pick up your brush by dragging downward from left to
right, the brush handle will attach itself to the lower right-hand
corner, whereas if you pick up the brush by dragging upward
from right to left, the handle will attach itself to the top left-hand
corner.

The Handle feature is especially important in the perspective
mode, because you can rotate a brush about its handle, whether
the handle is at the center or on one of the corners.

DeluxePaint’s Perspective feature (in the Effect menu) lets you
rotate a brush about any of the three axes of three-dimensional
space to define a plane of operation, and then work within that
plane to create perspective effects. Perspective is a big subject to
cover, so we've provided an entire chapter to cover it, Chapter 5,
Working with Perspective. If you are interested in 3D painting or
in 3D animation, be sure to work through Chapters 6 and 7.

48  Chapter 3 DeluxePaint IV




Fast FB

With Fast FB selected (in the Prefs menuy), lines, filled shapes,
and unfilled shapes are drawn with a single pixel line instead of
the full custom brush until you finish drawing, at which point
your shape is repainted with the custom brush. Try painting an
unfilled rectangle with a custom brush both ways to see how
Fast FB works.

DeluxePaint IV Screen

Hiding the Toolbox
and the Title Bar

Pages

Some of DeluxePaint’s features affect the entire screen, while oth-
ers, such as the tools and the brushes, affect the screen selec-
tively. This section considers those features that have a screen-
wide effect.

DeluxePaint lets you paint on the entire screen, even under the
Toolbox and the Title Bar.

» Toremove these two items from the screen, press the F10 key.
(Make sure your cursor is not in the Menu Bar area, or the
keyboard commands will have no effect.) This removes them
both if they are both present. Press F10 a second time to bring
them back.

» To hide just the Menu Bar (or to bring it back, if it’s hidden),
press F9.

Note that you can still access the Menu Bar even while it’s invis-
ible.

» Move the cursor to the top of the screen (except the upper left
corner) and press the right mouse button to display the Menu
Bar. You can now select any menu item in the regular fashion.

You can access the tools as well, even with the Toolbox hidden,
through the keyboard equivalents. See Appendix B for a com-
plete list of keyboard commands.

DeluxePaint gives you two separate pages with which to work.
You could use one of the pages for creating background images,
and the other for creating foreground images. You could then
move parts from one page to the other to complete your com-
position. When you are working on a picture, the spare page is
always the page you are not currently viewing. When you are
working on an animation, the spare page is identified with the
word Scratch in the Menu Bar; this page can be larger than the
screen, even though your animation frames cannot. As we shall
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Switching Pages

Page Size

see in a moment, the spare page is not entirely independent of
the other page or animation frames. For one thing, they share a
common Palette, almost as if they were the same picture.

When you first open a new file or load a picture from disk,
DeluxePaint opens one of the two pages.

» Load any image from the Picture drawer on your copy of the
DeluxePaint Art1 disk.

» To move from one page to the other, choose Spare>Swap
from the Picture menu, or press j on the keyboard to “jump”
to the other page.

When you do, you will notice that the Palette from the first page
follows you to the spare {second) page. This means that if you
modify the Palette for one page and then switch to the other
page, you end up modifying the second page’s Palette as well.
Note, however, that although the two pages share the same pal-
ette, you can have a different background color on each page. Be-
cause the background color is transparent, however, (see discus-
sion under Custom Brushes, above) any part of a brush consisting
of background color will remain transparent even if you move it
to the spare page with a different background color.

In addition, because the Toolbox is not really part of the page
(but actually sits “above” it), whatever tools you had selected
before you switched will still be selected after you switch pages.
This way, you can retain the same tool settings, giving you conti-
nuity as you work. Note that this continuity rule does not apply
to the Fix Background and Stencil commands, which do not carry
over from one page to the other. See the following section for
information on fixing the background, and Tutorial Three: The
World of Stencils in the next chapter for exercises involving the
Fix Background and Stencil features.

DeluxePaint lets you work on page sizes ranging from 320 pixels
wide by 200 pixels high, to 1008 pixels by 1008 pixels, depending
on memory availability. Note, however, that your page size can
never be smaller than the current screen resolution. For ex-
ample, if you are using HiRes 640x400 screen format, your page
cannot be smaller than 640x400. In addition to the three preset
page sizes (Standard; Full Page; Overscan), DeluxePaint lets you
specify any height and width through the Set Page Size re-
quester. To display this requester, choose Page Size from the
Picture menu.
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Modifying Tools

Built-in Brushes

Airbrush

Straight Line,
Curve, and
Unfilled Shape
Tools

A

You've already learned that you can activate any tool by clicking
its icon in the Toolbox. A tool remains active until you select an-
other tool or, in some cases, deselect it by clicking the icon a sec-
ond time. Examples of the latter kind of tool are the Grid and the
Symmetry and Magnify tools, which are toggled on and off by
each mouse click.

In most cases, right-clicking a tool icon lets you modify some
fundamental aspect of that tool. The following summarizes the
effects of right-button mouse clicks on the tools in the Toolbox:

You can change the size of any of the built-in brushes in the
Toolbox.

» Right-click the brush.

» Move the cursor over to the painting area. The word SIZE is
attached to the cursor.

» Hold down either mouse button and drag diagonally to
adjust the size of the brush.

You can adjust the Airbrush’s nozzle by right-clicking the

Airbrush icon.

» Right-click the Airbrush icon.

» Move the cursor over to the painting area. The word SIZE is
attached to the cursor.

» Hold down either mouse button and drag diagonally to ad-
just the size of the solid circle, which represents the spray
area.

A right-click on any of these tools brings up the Spacing re-
quester.

EERReTsL T T T
N Total 28 ]
Every Nth dot |z

Airbrush|  rem—

_Cancet| ok |

Figure 3.6 Spacing requester
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% When you load a custom brush, your painting mode is auto-
matically changed to Matte. Matte paints with the colors in
your custom brush.

» Drag the custom brush straight down your page to paint a
broad stripe of several greenish blues and reds.

» Click red in the Color Indicator.

» Now choose Color from the Mode menu and drag the brush
down again.

This time your stripe is all one color (red), because Color uses
the current foreground color and the shape of your custom brush
to paint.

» Choose Cycle from the Mode menu and drag another stripe.

Now your brush paints a stripe with bands of color running
horizontally. Notice that the colors change in the order of the
colors in your palette. Cycle uses the ranges in the Color Palette
requester and cycles the colors as it paints. This is a good ex-
ample of where ranges affect the way a painting mode works.

» Finally, choose MultiCycle from the Prefs menu. Select the
Straight line tool and drag a line straight down from the top
of the page.

MultiCycle tells DeluxePaint to cycle each color in your brush
individually when you use the Cycle mode. Since your brush is
made up of many colors, they create a many colored pattern.
Press the TAB key to see how psychedelic you can paint with
colorcycling and MultiCycle.

DeiuxePaint Smear Chal

“" - A -
A 7 SR

Figure 3.12 VENUS altered with Smear and Smooth brush modes
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» Choose Background>Fix from the Effect menu.

What you have just done is remarkably simple, and yet remark-
ably powerful. You have fixed the picture onto the background
so that it cannot be removed. Try it.

p» Click CLR and see what happens. That’s right — nothing.

The picture is fixed, which means you can draw over it any way
you like.

» Select a thick brush and scrawl on the picture. Do it with the
airbrush if you like. Then scrawl using the right mouse but-
ton and see what happens.

When you have the background fixed, painting with the right
mouse button is truly erasing! Note that you can paint on the
picture and then fix the background again to fix the new version.
You can erase everything you painted since the last fix with a
single click. And you can “unfix” the background as easily as
you fixed it: just choose Background>Free from the Effect menu.
This restores everything back to normal, so that clicking CLR
clears the entire picture.

We’ll look more closely at this feature in the next chapter when

we look at custom brushes and the way they interact with the
background. Meanwhile, feel free to experiment further with this ®
feature. Art restorers should have it so easy! (]

In particular, the combination of right-button brush selection and ®
Fix Background lets you lift any complex shape off a fixed back- @@
ground (provided the shape was applied after the background

was fixed), without lifting up any of the background. Deluxe- ®
Paint preserves in memory all those parts of a fixed background @@
that are covered by unfixed shapes, which means that you can

move the shapes around the page and uncover the previously ®
hidden background. @

Animpainting

We realize that you may have just started painting on a computer ®
for the first time. But we’ll take a daring leap forward to show ®
you animating on a computer. Right now we’ll show you a spe- @
cial kind of painting on multiple frames. Just follow the steps
carefully, and you’'ll see some wonderful results. ®
®
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Animation Frames

Animating with
Animpainting

» Choose AnimBrush>Load from the Anim menu. Insert the
Art2 disk in any drive and click the Disks button so that
<VOL> Art2 appears in the window.

» Click <VOL> Art2. It appears in the Drawer edit box.
p» Click <DIR> AnimBrush in the window.
» Double-click the file named “Sweep.anbr”.

When the requester closes, you’ll have an AnimBrush of a Karate
black-belt attached to your cursor. An AnimBrush is special in
that it is made up of many cels (short for cellophanes) that flip as
you paint.

» Choose Palette>Use Brush Palette from the Color menu to
see the brush in its own palette.

» Click the brush down once.
» Move the mouse, and click the brush down again.

Notice that now your brush looks different. Each time you click
the button the brush moves to the next cel.

p Paint freehand across the screen to see all of the cels of the
AnimBrush.

Above, we had you painting with an AnimBrush on a single
screen. Now let’s look at what happens if you paint one cel of the
brush on each of several screens. This is one way to create anima-
tions in DeluxePaint IV.

» Select dark blue as your background color and clear the
screen.

p Choose Frames>Set # from the Anim menu. (The Set Frame
Count requester appears.) Enter 20 in the Count field. (You do
this by clicking at the right end of the field, backspacing over
the existing number, and typing the new number.) Click OK.

In a flash, you have 20 animation frames to paint on. Notice the
numbers 1/ 20 on the left side of the Title Bar. This tells you that
you are on frame 1 of 20 frames. Let’s paint!

Animpainting is simply the process of painting at the same time
the animation frames flip. In most ways it is like regular paint-
ing, since DeluxePaint flips the frames for you.
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The four tutorials in this chapter introduce some of the most
powerful painting features of DeluxePaint IV. Though the tutor-
ials have a common theme — effectively using the program’s
colors — each tutorial is independent from the others, so you
can choose to complete only the exercises that interest you.

Tutorial One: ~ This tutorial will walk you through how to use the DeluxePaint
Working with Colors IV color requesters.

p Start DeluxePaint IV fresh, and at the Screen Format
requester, choose Lo-Res 16 colors.

Sixteen colors is far from the maximum number of colors you
can work with, but it is a good place for us to begin explaining
the color manipulation features of DeluxePaint IV. If you're fa-
miliar with DeluxePaint III, you will see that the program has
changed a bit to bring you more powerful color tools for work-
ing in HAM mode. These tools can also be useful in other modes,
as you'll soon see.

Manipulating the Palette In this section of the tutorial, we’ll look at the ways you can ma-
nipulate your palette. This will help you make best use of the
colors available to you in non-HAM modes.

The Toolbox Palette You may remember from the Guided Tour that the number of

(What You Can Paint with)  colors you can paint with depends on the Screen Format you
choose to work in. The important thing to remember in all modes
except HAM is that all of the colors you can paint with appear in
the palette area below the toolbox. If you are ever confused about
which colors are available to you, look at the Palette below the
Toolbox to see your colors.

Figure 4.1
Color Indicator and Palette

Of course, you can change these colors to create the ones best
suited to the artwork you have in mind. The common way to
change colors is to use the Palette Mixer.
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The Palette Mixer

Palette number —=2 3

RGB/HSV button —}J _= qlr
|

Palette action buttons —— G0 EX| SPREADI PICK| DELETEY

» Move the cursor over the Color Indicator and click with the
right mouse button.

Right-clicking on the Color Indicator displays the Palette Mixer.
You can also display this requester by choosing Palette>Mixer
from the Color menu, or by pressing p on your keyboard. Use
the method that is most natural for you.

COFY EX|S

Figure 4.2 The Palette Mixer

Palettes vs. Color Sets

One of the first things you'll notice about the Palette Mixer is
that it contains more slots than there are colors in your Palette.
In DeluxePaint [V you are able to mix and spread colors outside
your palette as a way to “experiment” with colors before com-
mitting to them in the picture.

There are 32 color slots to a row, and 8 rows numbered 0 through
7 for 256 color slots in the Mixer. We call this collection of slots
the Color Set. The Palette is a smaller number of colors included
in the Color Set. In the Palette Mixer, the Palette colors are ar-
ranged in row 0, and the top and left edge of each color is out-
lined in white. The top and left edge of non-palette colors is
outlined in light blue. When you are in a 16-color mode or HAM,
you can use the left edge of the Mixing Area as an additional
guide to where the first 16 palette colors end.

When you first open the Palette Mixer, you have only palette col-
ors and the rest of the slots are empty. Empty slots are indicated
with a checked pattern. If you try to paint with one of these color

slots, you'll see that the color is white by default.

Change palette arrows to
Palette colors see more of the Color Set

| : i

Current foreground color ~ Mixing Area

Figure 4.3 The Palette Mixer
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RBG/HSV Sliders

First let’s look at how you can change the colors that already
exist in your palette.

» Click on the bright red in the Palette Mixer and paint on the
screen.

As you can see, you can still paint on your image when the
Palette Mixer is displayed.

» Now, drag the sliders in the Palette Mixer to alter the red.

Notice that the color on the screen changes as you change the
color in your palette. The red in the Color Mixer is a Palette color,
s0 the color you placed on the screen is tied directly to the color
in the Palette. This is true of most Screen Format settings in
DeluxePaint IV. HAM is the exception. In HAM it is possible to
paint on the screen with colors that are not in your palette. We'll
explore these two color models in a moment in Introduction to
RGB and HSV Color Models.

» Click on the RGB button to change to HSV. Now use the HSV
sliders to alter the color some more.

DeluxePaint IV lets you set your color values using either the
RGB (red, green, blue) or HSV (hue, saturation, value) models.
You'll learn more about both of these color models in a moment.

UNDO

» Click UNDO in the Mixer to undo the change to the palette.
You'll see both the color in your palette and the color on the
screen restored to red.

You can undo any change to a color in your palette so long as
you don’t click any other color before you click UNDO. Undo
remembers and reverses only the most recent change. If you
wanted to return to the palette and color set you had when you
first opened the Palette Mixer, you would click REVERT. The
UNDO button makes it possible to experiment with colors in
your picture and return to the original easily if you don’t like
your experiment.

Copy and Exchange

You can rearrange the colors in your palette by using the COPY
and EX(change) buttons.
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SpeciaL NoOTE

p With the red color selected, click COPY and click on the first
empty slot to the right of your palette to copy the red there.

» Click the Yellow in your palette and copy it to the empty slot
beside the new red.

» With the new yellow color selected, click EX and click on the
new red to swap the positions of these colors.

Copy and Exchange are straightforward ways to arrange colors
in your palette. Perhaps the most important way you’ll use them
is to arrange your palette for creating spreads between colors.

Spreading Colors

Spreading colors is an effective way to get subtle shades of a
color. Let’s create a spread of colors from white to dark blue.

» Click on the white in your palette colors. Click SPREAD and
click on the dark blue at the right end of your palette colors.

Now you have a spread of colors from white to blue with the
color settings for each of the slots mathematically calculated to
give you the most evenly spread colors based on the number of
slots between the white and the blue. Note that DeluxePaint uses
the HSV model to build its spreads. This means that when you
spread between blue and yellow, the colors in between will run
through the greens in the color wheel.

Many other functions in the program (including Ranges) use the
RGB model to calculate spreads of color. It is important to under-
stand the distinction between these two color models and how
to use them to your advantage. If you aren’t already familiar
with these two color models, be sure to work through the section
Introduction to the RGB and HSV Color Models below for an
explanation of basic color theory.

Color Set

Now that there are no reds or yellows in your palette (though
there is one of each in your Color Set), we want to illustrate an
important concept.

Inn any color mode other than HAM, if you try to paint with a color
from the Color Set that is not in your palette, DeluxePaint paints with
the color in your palette that most closely matches the Color Set color.

Here’s an example:

» Click on the red in your color set and paint with it on the
screen.
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You should see that you are painting with the darker of the two
grays in your palette, because this gray is the color in your pal-
ette that is closest to red in the RGB color cube. (You’ll learn
more about the RGB color cube later in this section.)

» Click on the yellow in your color set and paint with it on the
screen.

You should see that you are painting with the lighter of the two
grays in your palette. As we mentioned above, the best way to
know which colors you can actually paint with when you are in
any screen format other than HAM is to look at the palette un-
derneath the Toolbox.

The Mixing Area

The mixing area lets you mix colors together the way an artist
mixes paint. Like the extra color slots in the Color Set, the Mixing
Area can contain any of the possible 4096 colors, but unless you
are using [ IAM mode, you will be able to paint only with the
colors you place in your palette. Let’s mix a new color right now.

» Choose the third round built-in brush from the toolbox.
Choose the red color from your Color Set and paint with it in
the Mixing Area. Then choose the yellow and paint into the
red.

You'll see the two colors mix together to form oranges. As you
mix, your brush spreads the mixed colors, but each time you
click down, your brush starts over with yellow automatically so
you can gradually add the yellow to the red.

To move your new color into the Color Set you use the PICK
button.

» Click on an empty slot in the Color Set. Click PICK. (Your
pointer changes to an eyedropper.) Click on a color in the
Mixing Area.

The color you clicked on is added to the Color Set in the slot you
chose.

To clear the Mixing area to any color and start over, you copy a
color to the color mixer.

» Click on white in the Mixing Palette. Click the COPY button.
Click in the Mixing Area to clear it to white.
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Loading and Saving
Palettes and Color Sets

Introduction to the RGB
and HSV Color Models

Arrange Palette Requester

Although we moved a few colors in the palette using the Palette
Mixer, the best place to accomplish this sort of operation is in the
Arrange Palette requester.

» Choose Palette>Arrange from the Color menu.

This requester lets you see four rows of colors at a time, and you
can quickly scroll through the other four rows with the up and
down arrows. Each click on the arrows to the right of the color
rows moves the rows up or down by one. The number in the up-
per left corner of the requester is showing you the number of the
row at the top of the list. When you are looking at the first four
rows (rows 0 - 3), this number is 0, when you're looking at the
last four rows (rows 4 - 7), the number is 4. If you hold down the
Shift key when you click on the arrows, you move directly to the
first or last four rows.

Figure 4.4 Arrange Palette requester

The buttons in this requester work just like the ones in the Palette
Mixer. The SPREAD option is especially useful in the Arrange
Palette requester because it lets you easily spread over multiple
rows in the set without having to scroll the rows.

DeluxePaint IV also lets you load and save Palettes and Color
Sets. If you continue on to the Ranges tutorial, you'll see an
example of loading a Color Set. Otherwise we recommend that
you look in the Reference for information on how to use these
features.

In this exercise, you'll be looking at the Reference Palette to learn
how DeluxePaint mixes red, green, and blue to form other colors.
You'll also see the relationship between the RGB and HSV (hue,
saturation, value) color systems.

» Choose Load from the Picture menu and load the picture
named Reference Palette from the Picture drawer of your
Art] disk.

% If you see the message asking if you want to change screen
format to that of the file, click Yes.
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Figure 4.5 The Reference Palette picture

The Reference Palette picture shows you a matrix of the colors in
the color spectrum: Red, Orange, Yellow, Green, Blue, and Violet.
These are the colors that are produced when you mix colored
pigment. In effect, these are the colors a traditional painter would
work with. This is not the spectrum produced when you mix
colored light. That spectrum produces the colors Red, Yellow,
Green, Cyan, Blue, and Magenta.

p» Choose Palette>Mixer On/Off to display the Palette Mixer.
Click on the main screen to activate it. Press F10 to hide the
Menu Bar and Toolbox. Place your cursor over the picture
and press the down-arrow key on the keyboard until the
ROYGBYV letters in the picture are at the top edge of the
screen.

Now let’s look at the RGB and HSV values of some of the colors
in the Reference Palette.

» Click PICK in the Palette Mixer and then click the red square
in the row labeled Pure Color. Look at the sliders in the
Mixer.

In RGB terms, your Mixer shows that a pure red is all red color
with no green or blue.

» Click the RGB button to change to the HSV sliders.

In HSV terms, pure red is hue 0 with full saturation and full
value. Saturation is the relative amount of color to white, and
value is the relative lightness'or darkness of a color. Value is
often referred to as Luminosity. To see exactly what this means,
let’s change the sliders a bit.
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» Drag the saturation (S) slider all the way to the left to see
what happens to the color. Drag the saturation slider back to
the right. Now drag the value (V) slider all the way to the left.

As you drag the saturation slider left, the red gets lighter until it
is white. As you drag the value slider left, the red gets darker un-
til it is black. Regardless of the hue or saturation, a value of zero
always produces black.

The meaning of the saturation and value sliders is exactly what
the matrix in the Reference Palette shows. Notice that the colors
in the Low Saturation row are all pale — they don’t contain
much color. The colors in the Low Value row are dark — they
don’t contain much luminosity. The colors in the Pure Color row
contain full saturation and full value.

Hue simply refers to the position of a color on the color spectrum
or rainbow — Red, Yellow, Green, Cyan, Blue, or Magenta, and
the various shades in between. Figure 4.6 shows the positions of
colors on the Color Wheel.

¥l Figure 4.6
The Color Wheel

Let’s look at another color in the Reference Palette.

» Click PICK and then click on the yellow square in the Pure
Color row.

p Click the HSV button to switch back to RGB sliders.
The RGB sliders show that yellow contains the maximum

amount of red and green, but no blue. Yellow is said to be the
“complement” of blue. Each of the primary colors has a comple-

76  Chapter 4 DeluxePaint 1V



ment. In the RGB color system, the relationship of the primary
colors and their complements are best thought of as a cube in
which each dimension is measured in one of the three primary
colors, as shown in Figure 4.7. The complement of each primary
color is positioned at the opposite corner of the cube. Thus, mov-
ing downward on the edge of the cube to add red to green pro-
duces yellow (R15, G15, B0) the complement of blue, which is
positioned at the opposite corner from blue. If you look back at
Figure 4.6 you’ll see that in the HSV color system, the comple-
ments are also directly across the circle from the primary color —
yellow is directly across the wheel from blue.

(0,0,0) Oy
Black | o

(13,0,0)

Red

{0,0,15)
Blue

Figure 4.7 RGB color cube

Notice that black is the absence of color (R0, GO, BO) and white is
the maximum level of the three colors (R15, G15, B15). The line
running diagonally through the center of the cube from black to
white shows the positions of the grays, which are formed by
combining equal amounts of red, green, and blue. Thus R8, G8,
B8 would yield a medium gray. Let’s try this in practice:

» In the Mixer, drag each of the RGB sliders to 8. Once all three
primary colors are at 8, you have medium gray.

» Click the RGB button to see the HSV slider. Look at the posi-
tion of the value slider in your Color Palette; it is at the same
level as the red, green, and blue sliders. (You can click quickly
back and forth between the two slider systems to confirm
this.)

The mixing of grays is one area where the HSV system excels.
Rather than moving all of the RGB sliders to the same position,
you can simply drag the saturation slider all the way to the left
and move the value slider to the level of gray you want. The
position of the hue slider will have no effect, because there is no
color (no saturation) in gray.
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Loading a Color Set

» Change your Screen Format to Lo-Res 320 x 200 with 32
colors.

Before you begin building a range, we’ll have you load a Color

Set that contains a pleasant spread of colors to paint the range
with.

» Choose Color Set>Load from the Color menu.

Load Color Set

Figure 4.8 Load Color Set requester

» When the first Load Color Set requester appears, insert you
Artl disk in the drive and load file Range.set from the Colors
drawer.

Once the Color Set is loaded, you are presented with a second
Load Color Set requester that is similar to the Arrange Palette
requester.

This requester allows you to choose which colors you want to
load from the color set to add to your current color set. And you
can choose to add colors to your current set, or you can over-
write the colors in your color set with the new colors. We want to
load all of the colors from this new color set and overwrite the
colors that are in our current color set. To do this:

p Click the Overwrite button.

The Overwrite button loads colors into your current color set
starting at color 0. After the Color Set is loaded, the Arrange Pal-
ette requester is automatically displayed so that you can arrange
the colors as you like. The Palette you’ll see contains two spreads
of color that paint smooth gradients even in the Low Resolution
mode we are using now. These spreads of color were created by
mixing the color at each end of the spreads in the Palette Mixer
and then using the SPREAD option to generate the colors be-
tween.
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Building the Range

Tip

» Choose Ranges from the Color menu to display the Range
requester.

A‘ r---— . . - > - - 4 : g : =
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Figure 4.9 Range Requester

The Range Requester is DeluxePaint’s new way of building
ranges for use in painting gradients or cycling colors. You can
build up to eight ranges for each document, and these ranges are
saved with the file. When you start the program, it contains a de-
fault set of colors in the first range. In our case, the default range
contains the grays in the lower half of the palette. We'll leave this
range in place and build a new one. The slider in the upper left
corner of the requester lets you choose the current range being
used by the program.

» Click to the right of the slider to move to range 2.

Range 2 should still be empty and ready for us to work with. To
build a range, you place colors on the bar just as you saw them in
the first range. [f Range 2 is not empty, click the CLEAR button.

» Click on the last yellow in the requester.

Your cursor becomes a rectangular bead, and the color indicator
in the upper right corner of the requester shows that you are
holding a yellow color.

» Move the cursor to the first mark on the range bar and click.
(Your yellow color appears on the bar and your cursor reverts
to an arrow.) Place the second yellow on the bar the same
way.

You can speed up the process of placing colors on the bar by
using the bracket keys [ ] to change the color of your color bead.
We'll do it now:

» Press the left bracket key [ to move to the next color in your
palette.

Your arrow cursor becomes a bead again and is holding the
new color.

» Click the bead in place on the range bar. Repeat pressing the
bracket key and clicking on the bar until you have all of the
yellow through orange and red spread on the bar.
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The Reverse Button

Pattern and Random Dither

% You don’t need to put the colors right next to each other on
the bar to build an effective range. And you don’t need to put
the colors in the same order that they appear in the palette.
We're doing this only because this is the most convenient way
to work with ranges in modes other than HAM. We'll show
you some other variations on ranges when we look at gradi-
ents in HAM and at Color Cycling later in this tutorial.

» Click the SHOW button to see the range painted as a gradi-
ent.

You'll see a gradient painted with your current range in both the
requester and in a bar above the requester. The gradient inside
the requester shows you the gradient using all of the colors avail-
able for that gradient in the Amiga color universe of 4096 colors.
If you are not working in HAM mode (and we’re not) the second
gradient appears above the requester to show you how the gra-
dient will look using your current palette. Since our range was
built from colors that exist in the palette, and we placed all of the
colors on the range bar, our gradient looks spectacular.

The REVERSE button beside your new gradient does exactly
what its name implies, it reverses positions of your colors on the
range bar.

» Click REVERSE once to see how it reverses the colors on the
range bar and repaints the gradients. Click the button a sec-
ond time to return the range to its original order.

At the moment, the gradients you see for your range are painted
using a regular pattern that produces an even transition between
colors. If you want to exercise a little more control over your
gradients or if you want to eliminate the smooth transitions
altogether, you can do this with the Random button and Dither
slider at the bottom of the Range requester. When you click the
Random button, your gradients are painted using a Random
dither that you control with the dither slider.

» Click the Random button at the bottom of the requester.

A check mark appears in the middle of the Random button when
it is selected. Notice that now your gradients are redrawn using a
random dither.

» Drag the Dither slider all the way to the right to see how this

affects your gradients. Drag the slider all the way to the left to
see the gradient with no dither.
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Gradient Fills

The Fill Type Requester

» Click the Random button again to turn off random dither.

Now that you've seen how most of the Range controls work, let’s
move on to painting with this range to see how it is used in gra-
dient fills.

As we mentioned above, one of the areas of DeluxePaint IV
where ranges are used is in the painting of gradient fills. There
are two general types of gradient fills to know about in
DeluxePaint IV. The first type of gradient is the linear style that
was supported by DeluxePaint III. The second is a “directional”
gradient that lets you specify the angle of any linear gradient,
and the central point for any radial style gradient. We'll show
you how to draw one of each of these gradients.

As mentioned in the Guided Tour, the Fill Type requester is
where you choose what type of fill your filled shapes and the Fill
tool will use. You display this requester by right-clicking on the
Fill tool or any filled shape tool.

» Right-click on the Fill tool in the Toolbox to display the Fill
Type requester.

Fill Tupe
F=ITT Brush|  Mrap |
Peﬁspoetivo|

Pattern |
From brush |

Range : 1m < | 2| |
Line I Shap I Cir | Con | Hi I

Dither: sl )

Randon | NN

Figure 4.10 Fill Type requester

The lower section of the Fill Type requester contains an assort-
ment of options for filling with a range. You can choose which of
your Ranges you want to fill with, and how the program should
perform the fill. The requester also shows you a representation
of your current range and lets you set the Random and Dither
options just as you would in the Range requester.
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Color Cycling Ranges

Conventional Color
Palette Cycling

still use the point where you clicked as the point from which the
gradient would radiate, and the effect would be different. Give it
a try if you like.

The figure below shows an example of each of the gradient fills
available in DeluxePaint IV drawn using the yellow to red gradi-
ent. If you like, experiment with the other gradient fill types and
play around with the Random dither setting too. We also recom-
mend that you try the radial gradients with different shapes to
get a feel for which combination of fill and shape gives the best
results. Of course “best” is entirely a matter of personal taste.

DeluxePaint Color

CIRCULAR CONTOURS HIGHLIGHT

Figure 4.13 Example of the eight gradient fill types

In the Gradient Fills section you learned how to use a range to
fill shapes with a gradient. You can also use these same ranges
and others to create color cycling animations. If you are familiar
with DeluxePaint IlI, you probably already know about the sim-
plest form of color cycling. This type uses ranges of consecutive
colors just like the one we built for painting the gradients in the
example above. DeluxePaint IV introduces two other types of
color cycling that allow you to use colors that are not in your
palette in a color cycling range. We’ll walk you very quickly
through each of the different versions of color cycling, and then
have you look at some color cycling brushes that are included on
your Artl disk.

The simplest form of color cycling makes each of the colors in the
cycling range move over to use the color in the next slot in the
range. This type of color cycling requires that you use multiple
colors from your palette to perform the color cycle. By cleverly
combining colors, you can simulate animation with this kind of
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Single Color Register Cycling

color cycling. There are several examples of this type of color cy-
cling on your Artl disk. Let’s take a look at two of them now:

The Running Man

» Choose Load from the Brush menu and load the Cycle2 brush
from the Brush drawer on the Artl disk.

Your Brush is now several images of a running stick figure.

» Choose Palette>Use Brush Palette from the Color menu to
change your palette to the palette of the brush.

» Make Color 0 your background color and click CLR to clear
your screen to black.

» Stamp down the brush and press the Tab key to start color
cycling.

Each position of the running man was drawn in a different color
from Range 1. Because five of the six colors in this range are
black, only one frame shows at a time, as the white color cycles
into each position in the palette. The remaining five images are
invisible against the black background. (Display the Color Mixer
and change the black colors in this range to any non-black color
to see all the frames.)

The Spinning Wheel

» Load the brush Cyclel from your Artl disk; stamp down the
brush and press Tab to turn on color cycling.

This color wheel was drawn as a circle with lines radiating out
from the center. The pie-shaped pieces were then filled with
adjoining colors in Range 2 of the Range requester. Thus, as the
colors in the wheel cycle, the wheel appears to spin.

The brushes Birds, Snowball, StormNight, and Fireworks are
other examples of this kind of color cycling animation. L.oad each
of them, change to the brush palette and turn on color cycling to
see how they work.

DeluxePaint IV also allows you to cycle a single register through
a range of colors. Rather than have you load an example to see
this effect, we’ll have you build one from scratch.

» Choose Palette>Default Palette from the Color menu.

» Display the Ranges requester and move the slider to range 2.
Click the Clear button beside the range to clear it.
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» Click on the third color in the palette (bright red) and place it
on the left side of the Range bar. Place the bright yellow in the
middle of the range bar. Click the Show button to show your
new range.

Now you have a gradient that runs from red to yellow in the
requester. (The gradient above the requester looks a bit less im-
pressive because you don’t have all of the in-between colors in
your palette to make a smooth gradient.) At the moment, your
range uses two color “registers,” that is colors from your palette
to build the range. You can tell that the colors on the Range Bar
are colors from your palette because each of the color beads has
a little dot beneath it. This little dot indicates that the colors are
from the palette. The secret now is to change the yellow to a non-
palette color. We do that by “picking” the RGB value we want
from the gradient in the requester.

» Press the comma (,) key on the keyboard to get the eye-drop-
per cursor. Move the cursor to the bright yellow area of the
gradient in the requester and click to pick that bright yellow
color.

A new bead is now your cursor and the color indicator in the re-
quester shows that the color is bright yellow.

» Click this new color bead directly over the yellow bead in
your range.

Notice that the new yellow bead on the Range Bar does not have
a dot beneath it. This indicates that the color is not from the pal-
ette, but instead is an RGB value that the program will use for
gradients and color cycling.

» Press the comma key again, pick a bright red from the left
side of the gradient and place it on the far right end of the
Range Bar.

Your Range Bar and gradient should now look like the one
shown in Figure 4.14.
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Figure 4.14 Range Bar with red and yellow range
using non-palette colors
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Hybrid Cycles

Tip

» Move the Rate slider in the requester three fourths of the way
to the right and click OK to close the requester.

» Choose the bright red in the palette and paint with it. Then
press Tab to start the colors cycling.

You should now see your bright red color cycle through orange
and yellow and back to red repeatedly. Notice that the red color
in your palette also cycles through orange and yellow, but that
no other colors in the palette change. You are cycling the color on
your screen but using only a single color register!

As you might well imagine, this new form of color cycling is
very useful for strobing effects of causing an area of your picture
to fade in and out without giving up a lot of colors to do it.

You can combine the conventional color cycling with RGB colors
in the range to create moving images that also strobe. We've in-
cluded a couple of these on the disk to give you the idea. Take a
look at them now if you think that you'll be using color cycling
in your pictures. These cycles are of special interest.

» Choose Load from the Brush menu and load the CycleCircle
brush from the Brush drawer.

» Choose Palette>Use Brush Palette from the Color menu to
change your palette to the palette of the brush.

Your Brush is now a blue and white circle.

» Stamp down the brush and press the Tab key to start color
cycling.

Notice that although the original brush did not contain any yel-
lows in it, as the wheel turns, yellow and gold colors strobe into
the cycle. If you display the Range requester and examine Range
1, you'll see a combination of palette colors (color beads with the
dot beneath) and RGB colors (without the dot). The brushes
Fountain and Lighthouse also use this range and demonstrate
practical uses for this type of color cycling.

If you want to create your own cycling pictures that use this
hybrid style of color cycling, create a conventional cycle range
first and paint the picture so that it animates correctly when you
cycle. Then add the RGB colors to the cycle range to incorporate
the strobing effect.
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Tutorial Three:
Painting in HAM

Before You Begin

The HAM Palette

Through the wonders of HAM mode, the Amiga computer lets
you paint with 4096 colors simultaneously. In the right hands,
this mode can yield wonderful results. If you are not already fa-
miliar with painting in HAM from some other product, it will
likely take you some time to get used to this mode. This section
will walk you through a tour of HAM as it is implemented in
DeluxePaint 1V. If you plan to work in HAM at all, we strongly
recommend that you work through this section.

» Start the program fresh and at the Screen Format requester,
choose Lo-Res 320 x 200 and HAM.

The first thing you'll notice when you start the program in HAM
mode is that the Toolbox Palette now has arrows and a letter in
the space below it.

Figure 4.15
The Color Indicator
and HAM palette

The arrows let you scroll through the colors in your Color Set,
and the letter tells you which of the groups of 16 colors you are
currently looking at.

» Click the right arrow below the palette several times to scroll
forward through the Color Set (most of the colors are blank).
Click the left arrow to scroll backward through the Color Set.

You can move quickly to the beginning or end of the Palette by
holding down the Shift key when you click the arrows.

» Hold down the Shift key and click the right arrow to move to
the last group of colors. Shift-click the left arrow to to move to
the first group of colors.

The first group of colors in the Color Set (the “a” group) contains
your actual Palette colors. The other colors are simply part of the
Color Set, but unlike in other modes, you can actually paint with
these extra colors.
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HAM Ramping

So what’s the difference between a Palette color and a Color Set
color in HAM? We're glad you asked...

When you paint in HAM, any colors that are not in your Palette
(group “a” of the colors below the Toolbox), are displayed on the
screen by copying the color in the pixel to the left and modifying
one of the RGB components of the color. (You'll find a technical
explanation of how this is accomplished in Appendix D.) Because
HAM mode can change only one of the color components at a
time, it can take up to three pixels to reach the color you really
want to paint with. This transition from one color to the next is
called a “ramp.” Let’s take a look at an example.

» Choose the largest square built-in brush and the Freehand
tool.

Press p to display the Color Mixer.

In the Mixer, Copy color 0 (black) to color 15 (magenta). Now
Click SPREAD and spread between the two blacks. This will
change all of your palette colors black.

v

» Click on one of the empty color slots in the row (remember:
the default color of these slots is white), paint a square on the
screen and press m to magnify it.

You should see that your white square has a ramp on the left
side. From black the color changes to green, then to yellow, and
finally to white. The ramp required three pixels to reach white
because the change from black to white requires a modification
to each of the R, G, and B components of the color, and there are
no intermediate colors.

o 3167 65553 £ 0 653 B3 83 €3 B3 £ £ €3 6
: &0l
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Figure 4.16 HAM Color Ramp from black to white

without intermediary colors
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Combining Images

HAM Fringing

Fast Adjust

Recompute

If you plan to combine images in HAM by loading in custom
brushes, it is best to create all of the separate images using the
same palette. This is especially true if you are using HAM
animbrushes to be combined with a HAM background.

We included a HAM background (AquariumBackground) and
two HAM animbrushes (AngelFish and BettaFish) on the Art2
disk for you to experiment with. These images all use the same
palette, so they combine fairly well. Load the background image
and create frames to use the animbrushes against the back-
ground. The brushes look especially good when stamped with
Translucency set to 30 percent.

When you load a 32 or 64 color brush into a HAM picture, the
brush is automatically remapped to use the current picture’s
palette. So the brush will immediately look correct on the screen.
The brush’s palette is also loaded intact, so you can choose
Palette>Use Brush Palette if you want to use the brush palette.
Then load the brush again to remap to the brush palette.

When you load a brush that is 16 colors or less into HAM, the
brush is not remapped. You can choose to either use the brush
palette or remap the brush.

Remember that DeluxePaint IV loads and saves palettes and
color sets. This should make it much easier and faster for you to
combine palettes.

Sometimes when you are moving a brush on the screen in HAM
mode, you will see fringe on the right side of your brush. This
happens when the colors in the picture are HAM colors, that is,
not from the 16 color palette. DeluxePaint attempts to correct the
fringing when you hold the brush still so that you can see how
the image will actually look when you stamp down the brush. If
you turn off the FastAdjust option in the Prefs menu (this option
in ON by default), DeluxePaint will attempt to correct the fring-
ing effect even when you are moving the brush. The advantage is
that your brush will always look its best, but the brush will also
move more slowly when you move it around on the screen.

HAM Fringing will be especially noticeable when you load im-
ages from some other programs that support HAM. If you load
an image from another program and find that the fringing effect
along the right side of your brush is severe, choose the Recom-
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Changing a Picture's
Colors in HAM

pute option in the Color menu. This option remaps the picture to
its own palette to eliminate the fringing.

Many artists are accustomed to adjusting the colors in their
image by changing the RGB values of the color in the palette and
thus automatically changing all instances of the color in the
picture. Since HAM colors are not tied to the palette, you cannot
directly change them by changing the RGB values. You can,
however, change the colors globally with the BG->FG option in
the Color menu. Here’s an example of how to do it:

» Choose Palette>Default Palette from the Color menu.

< Ifitis not already displayed, press p to display the Color
Mixer.

» Click on an empty color slot in the Mixer.

If there are no empty slots, create some using the Delete but-
ton in the Mixer.-Make sure the empty slots you create are not
one of the first 16 colors.

» Change the RGB slider settings to 12, 13, 0.

This should produce a bright yellow color that is slightly dif-
ferent from the yellow in the palette. Because it is not one of

the first 16 colors, it is a HAM color. Paint on the screen with
this new yellow.

» Click on another empty slot in the Mixer and change the RGB
sliders to 15, 3, 4. This should produce a bright red color.

» With the right mouse button, click on the yellow color you
created to make it your current background color.

At this point the Color Indicator in the Color Mixer should show
that your foreground color is bright red and your background
color is bright yellow. You should also have some of the bright
yellow background color painting in your picture. In the next
step, we’ll change the yellow color in your picture to the red
color.

» Choose BG->FG from the Color menu.

After a few moments, DeluxePaint repaints your picture with all
of the yellow turned to red.

The BG->FG option changes every instance in the picture of

your current background color into the current foreground color.
In our particular case this meant that every pixel in the picture
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Process

The Process options in the Effect menu let you paint with differ-
ent combinations of the HSV levels of your brush. Tint paints
with a combination of Hue and Saturation. Hue paints with only
the hue of the brush, if you're painting with a solid color, this is a
good way to convert a color image to a monochromatic image as
we’ll see in a moment. Value paints with only the value of your
foreground color, and is a great way to add shadows or high-
lights to an image, or even just to lighten the image overall. We'll
take a quick look at the Hue option to give you an idea of how
the Process options work.

» Choose Process>Hue from the Effect Menu to make it the
current process option. Then Choose Process>On/Off to turn
the Process option on.

A P appears in the Menu Bar to tell you that one of the Process
options is active.

» Press F10 to display the Toolbox. Choose the light pink as
your current foreground color. Select the Filled Rectangle
tool.

» Press F10 again to hide the Toolbox. Draw a filled rectangle
over the eye image in the upper right corner of the picture.

In a moment, the eye is painted over with pink and all of the
colors in the image are shifted to pink. Using the Hue option
does not affect the Saturation or Value of the colors in the image,
so the resulting image is a monochromatic version of the eye. If
you want to see the effect against the original, repeatedly press u
to undo and redo the change.

As we mentioned above, the Translucency and Process options
can be combined. Try some combinations of options on other
areas of the picture. For example, try the Tint option with Trans-
lucency set to a high number to very lightly tint an area of the
picture.

This section covered only a small part of the world of HAM
painting. We hope that the ideas we’ve presented here helped
you better understand HAM mode and that you'll experiment
freely with the new options designed for this mode.
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Sunrise in the Rockies

To lock a recently applied color, just select Stencil>Remake. You
don’t need to display the Stencil requester again, because the
configuration is still as you want it. This also means that you can
use the “Again” key (a) to update your stencil, if Remake was
your last menu command.

The Again rule is simple: press a whenever you want to repeat
the immediately preceding menu command, to save you moving
the mouse up to the Menu Bar and through menu and submenu
options. If your last menu command produced a requester, then
pressing a will produce that same requester, without the need for
menu selections.

In this exercise, we make the sun rise behind the mountains, so
we need to lock every color except the sky. Here’s how:

» Display the Make Stencil requester. (Color 8 should be the
only unlocked color in the requester.) Now click Color 8 to
lock it, and then click Colors 0 (black) and 12 through 16 (the
sky colors) to unlock them. (Color 12 is halfway down the
second column, and Color 16 is at the top of the third col-
umn.) Click Make.

You have now locked every color in the landscape except the sky
colors. Now let’s make the sun rise:

» Choose Stencil>Off from the Effect menu to turn the stencil
off.

In DeluxePaint IV, your stencil affects picking up a brush — you
can only pick up areas that are not in the stencil. Since the orange
shades in the sun are part of the stencil, you turned off the stencil
momentarily to pick up that area of the picture.

p» Click the Brush Selector, move the large cross-hair over to the
sun image (on the far right of the screen) and pick it up with
the left mouse button. Move the brush over to the mountain
range.

» Choose Stencil>On from the Effect menu to turn the stencil
on.

Did you see the sun move behind the mountains and then peek
through? This is because every color — except the sky colors and
the background— is locked, and so will not accommodate the
sun brush. When you are satisfied with the placement of the sun,
click to stamp an image of it there.
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Cutting Some Z's

Fixing the Background

In this exercise we will explore further aspects of DeluxePaint’s
powerful stencil editor. In particular, you'll see how to turn sten-
cil colors on and off from any part of your picture, not just from
the Make Stencil requester.

» Display the Make Stencil requester and click Clear to clear the
stencil. Now move the cursor outside the requester and click
the large Z shape. Click Invert and then click Make to return
to the painting screen.

Did you notice that when you clicked the Z the Make Stencil
requester responded by locking that color? This means that you
can lock and unlock colors directly from your image just by click-
ing them. Note that clicking with the left mouse button adds a
color to the stencil and clicking with the right mouse button de-
letes a color from the stencil. And to make it easy to find the col-
ors you want to lock or unlock, you can move the Make Stencil
requester to any part of the screen just by moving the cursor to
the top of the requester, pressing the left mouse button, and
dragging it to a new position.

Now let’s see what we can do with the stencil we just created:
» Pressthe * (accent grave/tilde) key to turn off the stencil.

Pressing ° is the same as choosing Stencil>On/Off from the
Effect menu. This is a very important keyboard equivalent for
working with stencils.

» Click the Brush Selector and pick up the textured area to the
right of the Z.

» Press " to turn on the stencil.

» Move the cursor over to the Z and watch what happens.

Did you see the textured brush appear behind the Z? Because all
the colors except the Z are locked, it looks like you're viewing
the textured brush through a Z-shaped window. Now, when you
place the textured brush behind the Z and click, you will fill the
Z with the textured pattern.

By using a combination of stencils and fixing the background,
you can define a stencil by area rather than color. This lets you
confine a stencil to a particular area of the page, without forcing
you to lock every instance of a particular color. Let’s take a closer
look:
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Fine Tuning the Stencil

» Click in the Tolerance edit field and change the number to 8.

» Click SHOW once to turn off the option, and when the image

has updated and the requester reappears, click Show again
to recalculate your stencil with the new Tolerance setting and
show it.

Now you'll see that two thirds of the greens are selected in your
image.

o,
o

If you need to select a large area of your image quickly, high
tolerance numbers can help you a lot. However, to get that
help you sacrifice some control over which colors get sten-
ciled. Of course, you can always go back and adjust the
stencil with the Fine Tune option as you'll see below.

Now that you've seen how to add to the stencil and use the Tol-
erance setting, we’ll take a quick look at fine tuning the stencil.

We
cil,

| 4
| 4

>
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‘re going to use Fine Tune to subtract a color from your sten-
but you can also use Fine Tune to add colors to the stencil.

Click the Fine Tune option to turn it on.

Move the cursor over to the middle of the stenciled grass and
click with the right mouse button to subtract a color.

Click SHOW once to turn off the option. Click SHOW again
to recalculate and show your stencil with the color removed.

e Tune lets you add or subtract single colors from your locked
without having to change the Tolerance level. Fine Tune al-
ys adds or subtracts only the color you click on, though you
certainly welcome to click on whatever colors you like.
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Moving in 3D Space

Moving on the Z axis

rotations in the exact same order. You'll notice that the angles
given in the Menu Bar when you rotate using the Brush coordi-
nates are actually the angles for the Screen coordinates system;
this is so you will be able to reproduce your brush rotation,
though you will have to use Screen angles to do it.

Now that you’ve seen how to rotate your brush in three dimen-
sions, the next section will show you the ins and outs of moving
a brush around in all three dimensions.

Before you begin this section clear the screen.

» Choose Perspective>Reset from the Effect menu to reset all
perspective settings, including Angle Type, to their defaults.

» Load the brush named Blockbrush from the Artl disk.
Choose Palette>Use Brush Palette from the Color menu.

» Make sure you are in Perspective mode.

When your brush is in its original orientation (0, 0, 0), moving
your mouse moves your brush along the X and Y axes. Try it
right now:

» Move your mouse forward and watch how your brush moves
up on the screen. Move your mouse backward and your
brush moves down on the screen. Likewise, moving the
mouse left or right moves the brush left or right.

Because your mouse can move in only two dimensions (the third
direction would require you to lift it off the desk), it can move
your brush in only two directions. You can move your brush in
the third dimension by using the keyboard. One method is to
move the brush straight back along the Z axis only:

» Position your brush in the lower left corner of the screen,
hold down the Shift key and press the quote key (“) several
times.

Each time you press Shift-", the brush moves backward along the
Z axis. It appears as though the brush is getting smaller, but in
fact it is moving away from the front of the screen. To move the
brush forward along the Z axis, you use the colon key(:).

» Hold down the Shift key and press the colon key (:) once.
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3D Coordinates

Laying Down the
Brush to Move in 3D

Notice that the " and : keys move the brush toward and away
from the cross hair in the middle of the screen. This cross hair de-
fines the Perspective Center, which is best thought of as the point
of view. No matter where you place the brush on the screen, if
you move the brush using the quote key, the brush will move
into the distance and toward the Perspective Center.

When you use Perspective, you'll often want to move your brush
backwards and left and right along a plane. The effect is of a
brush moving across the floor. DeluxePaint lets you do this by
holding down the Ctrl key while in Perspective.

» Press 0 to reset your brush to its original orientation.

» Position the brush near the bottom of the screen, hold down
the Ctrl key and move your mouse forward and backward.

With the Ctrl key held down, the brush moves away along the Z
axis when you move the mouse forward. In this way, you can
easily move in the X and Z axes instead of the usual X and Y
axes.

DeluxePaint IV lets you see the position of your brush in three
dimensional space when you are in Perspective mode. This is
useful if you need to align your brush precisely.

p Pressthe \ key and look at what happens to the angles in the
right side of the Title Bar. Now hold down the Ctrl key and
move the mouse forward and backward.

Pressing the \ key toggles the Display option in the Perspective
requester between Angle and Pos (position) (see Figure 5.7).

» Press the \ key again to return to displaying angles in the
Title Bar.

Another way to move into the distance is to lay the brush down
and then move it on its own Y axis. Rotating the brush 90° on its
X axis makes the brush’s Y axis act like the screen’s Z axis. Figure
5.11 shows what happens to the different axes during perspective
rotation.
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Perspective Plane
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Brush’s original Y axis
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Figure 5.11 Brush coordinate system before and after rotation

Let’s try it once to see how it works.

» DPress 0 to reset the brush to its original orientation and
position the brush in the lower left corner of the screen.

» Press Shift-7 to flop the brush down into the screen.
Now move the mouse around.

You will quickly discover that moving the mouse forward and
backward moves the brush into the screen and back out instead
of up and down. This is because the mouse moves the brush on
the plane defined by the brush’s X and Y coordinates.

» Move the brush to any new position and press Shift-8 to
turn it back up on end. Paint the brush down.

» Use the combination of Shift-7 and Shift-8 several times until
you are comfortable with how these keys help you move in
the third dimension.

You might have noticed that when you flopped the brush down
by rotating on it’s X axis, the brush moved on a plane below the
Perspective Center. Remember that when the brush is in its ori-
ginal 0, 0, 0 orientation, it moves on a plane that is roughly the
equivalent of the computer screen. When you rotate the brush,
you change the orientation of the plane. The plane can be at al-
most any angle to Perspective Center. The easiest way to see this
is to fill the perspective plane you've defined.
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brush three times above the current brush position so you
create the face of a column.

» Paint the brush four times to the right to form the top of the
arch and the top of the right column. Then paint the brush
three times down to form the right column.

At this point you have a two dimensional arch on a three dimen-
sional plane. Our next task is to give the arch a third dimension.

» Move the brush so that it is directly on the bottom block of
the left column of your arch. Press Shift -4 to rotate the
brush 90° on the y axis. Paint the brush where it is and twice
above to form the left side of the column.

» Move the mouse a bit to the right to move the brush back
along its x axis and paint another set of blocks so your col-
umn is one block wide at the face and two blocks deep as
shown in Figure 5.14.

» Press Shift-5 to rotate the brush back on its Y axis so that it
is facing you head on. If the brush is not the same size as the
facing blocks of your arch, hold down the Ctrl key and move
the mouse forward or backward to bring it closer or move it
back.

*,
'’

% Remember, the Ctrl key temporarily fixes the Y axis of your
brush so that you can move it on it’s Z axis. As you become
adept at painting in Perspective, you'll find yourself using
this key often.

» Position the brush to the left of the bottom block of the right
column. Press A1t -x to change the brush handle to the other
side of the brush.

Your brush jumps so that it is over the bottom block of the right
column, but the brush is now held by the lower left corner. Re-
member that Alt-x, Alt-y, and Alt-s reposition your brush handle.
These keyboard equivalents are especially useful while working
in Perspective, since you usually don’t want to move your
mouse to choose from a menu.

» DPress Shift-5 to rotate the brush 90° on the Y axis. Paint the
brush where it is and twice above to form the left side of the
column. Paint another column just behind this first one so
your column is one block wide at the face and two blocks
deep.

» Press Shift-4 to rotate the brush back on the Y axis. If the
brush is not the same size as the facing blocks of your arch,
hold down the Ctrl key and move the mouse forward or
backward to bring it closer or move it back.
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Inserting the
Seascape Picture

>

Move the brush up so that it is over the block in the upper
left corner of the arch. Press Shi ft -7 to rotate the brush -90°
on the X axis. Move the brush to the right and stamp it once
below each of the three blocks that form the top of the arch.
Paint another row just behind this first row so the top of your
arch is one block high and two blocks deep.

Now your arch is complete and should look just like the arch in
Figure 5.14.

To give your perspective painting a bit more color, and a land-
scape for the background, we'll load the Seascape picture and
add it behind the arch.

>

>

| 2

>

Choose Spare>Swap from the Picture menu to display the
spare page
Load the Seascape picture from the Picture drawer on your

Artl disk. Choose Palette>Default Palette from the Color
menu.

Jump back to your main page (press j or choose Spare>Swap
from the Picture menu).

Choose Spare>Merge in back from the Picture menu.

In a flash, your arch has a nice seascape backdrop.

This exercise gave you a quick example of perspective, but you
can do a lot more. For an excellent example of perspective at
work, load the picture Hall-of-Stars on your Art1 disk.
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Before You Begin

This chapter introduces you to DeluxePaint IV's animation features.

It begins by explaining the basic model for animation and then covers
each of the different ways to create animations with the program. We

recommend that you work through this chapter in one sitting. It will

take you approximately 45 minutes to complete.

If you’ve been experimenting with DeluxePaint for a while be-
fore starting this chapter, it would be a good idea to quit the
program and restart. If you start the program fresh, there is less
chance that the results you get from following our instructions
will be different from what we describe.

» When the Choose Screen Format requester appears, click Ok
to use the default settings (Lo-Res, 320x200, and 32 colors).

 If your computer has only 1 MB of RAM, we recommend that
you load the program in Swap mode.

The Basic Model

The basic idea behind animation in DeluxePaint is that instead of
having a single page to paint on, you have multiple pages that
you can paint on and flip through. By creating images that differ
slightly from page to page and then playing them back in rapid
succession, you create the illusion of motion.

Figure 6.1 The Basic Model

This section shows you how to:
create frames for your animation
paint on individual frames in the animation

paint while the frames are flipping—this is called
Animpainting™.

use the Animation Control Panel
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Creating Frames

Painting One
Frame at a Time

The first step in building an animation is to create the frames to
paint on.

p» Choose Frames>Set # from the Anim menu. The Set Frame
Count requester appears.

Set Frame Count
Count: I
Cancel | Ok

Figure 6.2
The Set Frame Count requester

» Click in the Count edit box, change the frame count to 10 and
click Ok.

You now have 10 frames to paint on. Notice the numbers 1/10 at
the left side of the Title Bar. This means you are positioned on the
first frame of a 10 frame animation.

The most basic way to create an animation is to paint on each
successive frame individually.

» Select the largest round built-in brush and paint a dot in the
upper left area of your screen.

The dot you just placed is on frame 1. The trick of animation in
DeluxePaint is to paint a slightly different picture on successive
frames. So you need to move to the next frame.

p Choose Control>Next from the Anim menu to move to frame
2. (Notice the Title Bar shows 2/10.) Click another dot to the
right of where your first dot was.

Now you have a dot on frame 1 and a dot on frame 2. To create a
series of dots that move across the screen, you just repeat the last
step. You'll notice that changing frames from the menu is a little
cumbersome, and it forces you to move the mouse from the
painting area. It's much more efficient to move through the ani-
mation frames by using the keyboard equivalents (listed in the
menu beside the options). Follow the numbered steps below and
we’ll use keyboard equivalents to complete and play our little
animation.

1. Position your brush just to the right of the dot you painted on
frame 2.

2. Press 2 on the keyboard once, then click to paint a new dot.
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p Click in the Dist edit box below X and set the number to 200.

» Make sure that the Count edit box (in the middle of the re-
quester) shows 20 as the current setting. If the number is not
20, click in the edit box and change the number.

» Click Preview to see a preview of the movement of your
brush.

You will see your brush enclosed in a wire frame move to the
right across the screen. If you want your brush to move to the
left, you enter a negative number for the X Distance. Try it.

p Set the X Dist edit box to -200. Click Preview.

This time your brush moves to the left across the screen. A sim-
ilar rule applies to the other two axes: Y Distance moves your
brush upward if the number is positive and downward if the
number is negative. Z Distance moves your brush out to the
distance (away from you) if the number is positive or inward to
the screen (coming toward you) if the number is negative.

You can use any combination of the three Dist edit boxes to move
your brush anywhere in three dimensional space. Try it if you
like. Set a number for each of the three boxes and click Preview
to see where the brush would move.

Simple Rotation In addition to moving the brush along an axis or several axes in
combination, the Move requester lets you rotate the brush
around one or more axes. You rotate the brush by entering num-
bers in the Angle edit boxes.

» In the Move requester, click Clear, which clears all data from
the Distance and Angle edit boxes.

» Click in the Z Angle edit box and enter 360 as the angle of
rotation. (This tells DeluxePaint that you want to rotate the
brush 360° on the Z axis.) Click Preview.

You'll see a wire frame representation of your brush rotate clock-
wise on the screen. Just as negative numbers change the direction
of movement when using Distance moves, negative numbers
change the direction of rotation when you use Angle moves.

» Change the Z Angle setting to -360° and click Preview.

The wire frame rotates counter-clockwise.
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Cyclic and Non-
Cyclic Moves

Cyclic Animation
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Figure 6. 9 Results of two successive moves with Go Back

You use the Cyclic button to tell DeluxePaint which of two kinds
of animation you want:

an animation that will loop back on itself (cycle) or chain
from the current move to another move of a similar type; or

an animation that is linear and will end at the last frame you
requested in the Move requester.

DeluxePaint draws your move differently depending on whether
or not the Cyclic button is selected. In this section we’ll give you
a very quick example of the difference between the two moves.

For purposes of this exercise, the number of frames in your ani-
mation should be 20.

» Load any brush that contains features to help you tell
whether or not the brush has been rotated. (The DPaintTitle
brush will do very well.)

» Click CLR and clear all frames. Stamp the brush in the upper
half of the screen.

» Display the Move requester. Click Clear in the requester. Set
the Z Angle to 360.

» Click the Cyclic button so a Y appears in the box. Click Draw.
When DeluxePaint is finished drawing your animation, notice
that you are on frame 1 of your animation. DeluxePaint moved

you to the frame past the ending frame of your Count.

» Press Shift-2 to go to the last frame of the animation.
(20/20 appears in Title Bar.)
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Tip

You should be able to see that the rotation at the top of the screen
is smooth, but the rotation at the bottom of the screen hiccups
noticeably.

You might ask yourself at this point why anyone would want
Cyclic turned off. The answer is simple: you might want to rotate
exactly 90° by a particular frame or you might want to move an
object from point A to exactly point B. Generally, if you are creat-
ing an animation sequence that runs for less than the full number
of frames you have allocated for your animation, you don’t want
Cyclic turned on. For a clear example of why you would want
Cyclic turned off, follow the next set of steps.

» Clear all frames of your animation. Press Shift -2 to move
to the last frame.

» Select the Unfilled Circle tool and the single-pixel brush and
draw a small circle on the right side of the screen.

» Choose Coordinates from the Prefs menu to turn on Coor-
dinates.

» Select the Dotted Freehand tool and the largest round built-in
brush. Position the brush in the middle of your unfilled circle
and note what the Coordinates show as the location of the
brush.

» Move the brush 200 pixels to the left of that position, press
Shift-1 to move to frame 1 and stamp down your brush.

When you need to move your brush in a straight line horizon-
tally or vertically as you did in the step above, hold down the
Shift key. This constrains your cursor to horizontal or vertical

movement, depending on which direction you move in first.

» Display the Move requester, click Clear, set the X Distance to
200, make sure Cyclic is selected, and click Draw.

When DeluxePaint finishes drawing the animation, notice that
you are left on frame 1. Now look at frame 20 (press Shift-2).
You'll see that even though the distance from where you
stamped your brush to the center of the circle was exactly 200
pixels and the move you requested was 200, the dot did not
reach the center of the circle. If you want to move your brush to
a specific location by your ending frame, turn Cyclic off.

Figure 6.12 shows the results of the steps above with Cyclic
selected and not selected.
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» Choose AnimBrush>Settings from the Anim menu. Set the
Duration box to 20. Set the Current box to 1 to put the brush
at its first cel. Click Ok.

Now position the karate figure on the right side of the screen.
Hold down the Alt key and paint one cel of the AnimBrush on
each of the 20 frames.

When you've finished painting your AnimBrush on the 20
frames, press the 4 key at the top of the keyboard to play the
animation.

Compare the speed of the two characters. If you step through the
frames of your animation one at a time, you’ll see that the man
on the right takes two frames before changing position, while the
man on the left moves on every frame. You can also use Duration
to speed up an animbrush by setting the duration number lower
than the number of cels in the brush. In that case, cels of the
brush would be skipped as you painted with the brush.

< If you increase the duration of an AnimBrush, it is best to set
a duration that is a multiple of the number of cels in your
brush. For example, an AnimBrush that has 10 frames will
generally look best if you set the duration to 10, 20, 30, etc.

Metamorphous Another way to create AnimBrushes is to transform the image

AnimBrushes and shape of one custom brush into those of a second custom
brush. This special feature, called metamorphosis, can create
some stunning effects. We’ll show you a couple of very simple
examples just to give you the idea. The first example metamor-
phoses between very different brushes. The second example
metamorphoses between two transtormed versions of the same
brush. In both examples, you’ll use the Spare options in the
Brush menu to work with two custom brushes at the same time.

The Chicken and the Egg In this example, you'll load two different custom brushes (a
chicken, and an egg) and create an AnimBrush that metamor-
phoses between the two.

p» Clear all frames of your animation.

» If the Animation Control Panel is NOT on your screen, press
Alt-Atodisplay it.

» Choose Load from the Brush menu, and load the file named
egg.brush from the Brush drawer on Art1. Choose
Palette>Use Brush Palette from the Color menu.
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The LightTable

Simple “Tweening

B8l The LightTable lets you see a few frames of animation overlayed

on each other like clear sheets of cellophane to help you position
brushes or paint the in-between frames of a character animation.
The LightTable can also dim the frames that are behind (or after)
your current frame so that you can more easily see which frame
you are working on. (This dimming effect is available in all
modes except HAM.)

Traditional animators work by painting the key positions or
poses of a character and then paint the “in-between” frames to
create the smooth transition between poses. The LightTable is
ideal for creating animation with this traditional approach. In
the next few pages, we'll introduce you to the basics of using
the LightTable through an exploration of the techniques used
to create the Doggie’s_Inferno animation on your Art2 disk.

We'll start out with a simple example of painting a smiling face.
To begin, we need a clean frame to work with.

p Delete all frames. Choose Palette>Default Palette from the
Color menu.

» If the Animation Control Panel is not on your screen, press
Alt-a todisplay it.

% The most obvious place to access the LightTable feature is
from the Anim Control Panel, and this is the method we'll
use in this example. However, if you prefer, you can also
access this feature and its options from the Effects menu, or
from the keyboard. Check Appendix B for keyboard equiva-
lents.

» Click the + button on the Anim Control Panel to add a frame.
p Choose AnimBrush>Load from the Anim menu and load the
brush Smile from the AnimBrush drawer of your Art2 disk.

This AnimBrush has only two cels, one frame shows a simple
unexpressive face, the other shows a smiling face. We'll stamp
these down on our two frames and then look at how the
LightTable helps us create the in-between frames.

» Drag the Frame Slider in the Anim Control Panel to the left to
move to frame 1. Stamp the first cel of the Smile brush on
frame 1.

» Drag the Frame Slider to frame 2.
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Merging in the Background

» Choose Spare>Swap from the picture menu to put the back-
ground picture on the spare page.

» Load the anim DoggieOutline from the Anim drawer on your
Art2 disk. When the message appears to ask if you want to
change the number of colors to that of the file, click No.

% You just performed an important operation; you loaded an
8-color wire-frame animation into 16-color mode. Deluxe-
Paint lets you load animations into screen formats that use
more colors and thus makes it possible for you to create the
initial animation outline in just a few colors and load it into a
format with more colors later on when you want to paint the
frames.

DoggieOutline is a few frames of a simple wireframe animation.
(The original outline animation was created in Interlace mode,
but we converted it to LoRes so that you wouldn’t see the
flicker.) The Doggie’s_Inferno animation (which we’ll load in a
moment) was created by an animator who uses the traditional
method of first drawing the outline version of the animation and
then filling it with solid colors or patterns to create a finished
piece. Traditional animators call the outline version of an anima-
tion the “pencil test.”

» Turn on the LightTable to view the animation frames
overlayed on one another.

» Click the S button in the Anim Control Panel to view the
Spare page behind the animation.

See how useful it is to view the background image through your
animation frames? With the background visible, the animator can
easily align the animated characters without having to worry
about accidentally ruining the background image. Even if you
aren’t working on an animation, you might find it useful to view
a background image while you paint. If you turn off the Dim op-
tion (from the LightTable submenu of the Effects menu) you can
view the background in its original colors and thus treat your
animation frame as a transparent page.

» Choose different combinations of settings (2, B, N, and S) in
the LightTable area of the Anim Control Panel. Move the
Frame Slider back and forth to view the different animation
frames and background combined with the various settings.

One of the powerful features of the LightTable is its ability to let

you merge your viewed frames. We'll try it right now by merg-
ing the background image into the image on one of the frames.
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The Painted Animation

» Make sure LightTable is on, but turn off all of the LightTable
options other than S (for Spare).

You should see your current frame against the background on
the Spare page with no other frames visible.

» Choose LightTable>Merge from the Effects menu.

In a moment, your background is merged with your wireframe
animation. Notice that the LightTable is automatically turned off
after a merge operation. This is done so you will see the frame in
its actual state and not be confused by LightTable effects. One
caution is in order: you can’t Undo a merge, so you should be
very careful that the image as you see it in the LightTable is
correct before you merge it.

Another way to merge the background image with the frames is
to use the Spare>Merge in Back option in the Picture menu. This
option lets you merge to the current frame, to a range of frames,
or to all frames in a single operation. This is generally the last
step an animator takes in the creation of a finished traditional
piece. If you have enough memory in your Amiga, you can try it
yourself after you view the painted animation frames in the next
section.

Before we leave this section, we'd like you to load the
Doggie’s_Inferno animation and, if possible, merge it with its
background. We've included two sets of instructions: one set for
those with less than 2MB of RAM, and one set for those with
2MB or more.

If you have less than 2MB of RAM:

» Choose Load from the Anim menu and load the
Doggie’s_Inferno animation from the Anim drawer of the
Art2 disk. When it has finished loading, press 4 on the key-
board to play the animation.

Be sure to read the Tip below! If you don’t have a lot of RAM, it
is an especially useful tip.
If you have 2MB or more of RAM:

p Choose Frames>Delete Frames from the Anim menu. In the
requester, click Delete All.

» Choose Load from the Picture menu and load the

DoggieBackground picture from the Picture2 drawer of the
Art2 disk.

153 Animation Basics DeluxePaint IV









Rotation on the
Brush's Axis

The wire frame model of your brush moves upwards, just as you
would expect when moving along the screen axis.

p Click the Brush button beside the Distance edit boxes. A
check mark (V) appears in the box. Now click Preview and
watch the direction the brush moves.

This time the brush moved into the distance along the Y axis of

the brush. As Figure 6.15 above shows, the brush’s Y axis is the

same as the screen’s Z axis when you rotate backwards -90°on X
as we did.

You may have already guessed what will happen when we rotate
the brush on it's own axes rather than on the screen axes, but this
is sometimes difficult to visualize, so we’ll give an example.

» Click Cancel to close the Move requester

p» Click CLR and click All Frames in the requester to clear all
frames.

» Choose Perspective>Reset from the Effect menu to reset all of
the Perspective settings.

At this point you once again have your brush in the original ori-
entation and are in Perspective mode. Now we’'ll rotate the brush
on the Z axis, so that the X and Y axes of the brush no longer
match the X and Y axes of the screen.

» Hold down 2 on the keypad until the brush has rotated 45°
on the Z axis. You'll see the degrees of rotation in the right
side of the Title Bar.

Paint down the brush in the middle of the screen.
Press M to display the Move requester.

Click Clear in the requester.

vV v vy

Click Load. When the Load Move requester appears, load the
file called Animbasics2. Move from the Move drawer of Artl.

Make sure the Brush button beside the Angle edit boxes
doesn’t have a V on it.

v

p» Click Preview.

With the settings above, you'll see the brush tumble toward the
screen on the X axis. Remember that the brush is rotating on the
screen’s X axis. Now let’s look at a rotation on the brush’s X axis.
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Curving Titles

Tip

» Step to frame 40.

Now you need to create a stencil so you can “paint behind.”

» Choose Stencil>Make from the Effect menu. In the Make
stencil requester, click the background color (black), click
Invert, and click Make to lock all colors but the background.

» Display the Move requester. Leave all of the other settings the
same, but select the backwards Record Direction. Click Trails.

Because you reversed the Record direction, DeluxePaint begins
this move by painting on frame 40. It then steps one frame back-
wards and paints the cumulative effect of frame 40 and the new
brush position on frame 39. This is where the Stencil comes into
play. Because the colors in the title are stenciled, the second
brush stamp appears to be painted “behind” the single image
that was stamped on frame 40. Though, in fact, it was painted
over the single image.

The resulting animation should have your brush moving from
the distance, leaving Trails, until it gets to the nearest position,
at which point the Trails start erasing from the back forward.

» Before you move on to the next effect, choose Stencil>Free
from the Effect menu.

This example shows you how to create the effect of a title moving
across the screen on a curved path using the curve tool instead of
the Move requester.

» Clear all frames.

» Load the DPaintTitle. brush from your Artl disk. Choose
Palette>Use Brush Palette from the Color menu.

» Go to the last frame (frame 40) and stamp the brush near the
bottom of the screen. Click Undo.

Clicking UNDO immediately after stamping the brush helps
ensure that your results are what you expect. This is particularly
important if you are using a Brush Mode in your move, because
DeluxePaint paints on the screen you stamped on when it paints
the move, and stamping twice on the same screen will give a
different result from a single stamp.

» Display the Move requester, and click Clear.

» Set the Z distance to -1200. Select the Come To option. Set
Count to 40, and click Draw.
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Tumbling 3D Objects

DeluxePaint paints the brush moving toward the screen from the
distance.

» Pick up the animated title as an AnimBrush. (Be sure you are
on frame 1 when you pick up the brush, and that you enclose
the entire area over which the brush moved.)

» DPress Alt-x to place the brush handle in the lower right
corner of the brush so you will be able to click it off-screen.

p Clear all frames.

» Right-click the Curve tool to display the Spacing requester.
Click the N Total button and set the total to 40. Click Ok.

The Spacing requester lets you tell DeluxePaint exactly how
many brush stamps you want to use to paint your curves, lines,
and unfilled shapes. By setting the Spacing to N Total of 40,
you'll get 40 stamps of the brush. Since you have 40 frames,
when you use the brush to animpaint, you'll get one stamp of
the brush on each frame.

» DPress shift-7 to go to the first cel of the AnimBrush.

» Dosition the brush at the left side of the screen and midway
between the top and bottom.

» Hold down the Alf key and the left mouse button and drag
down to the lower right corner of the screen. (You'll see your
title drawn along the path of your curve.)

» Release the mouse button and define the shape of the curve
while still holding down the Alt key. When the curve is a
shape you like, click to begin animpainting.

When DeluxePaint is finished painting your curve, press 5 to
play the animation once. You’ll see the brush move into view
and curve it's way down to the lower right corner of the screen.

Like the Curving Title effect above, this effect also uses the curve
tool to move an AnimBrush along a curved path. However, in
this effect, you use an object that looks three-dimensional, and
you tumble it at the same time you move it toward the screen.
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Planetary Orbits—
Brush Handles

Now you have your AnimBrush of the object tumbling and mov-
ing toward you. In the next steps, you’ll use the Curve tool and
the Spacing requester to give it a trajectory across the screen.

p Clear all frames.

» Right-click on the Curve tool. Set the Spacing requester to N
Total 40.

» Place the brush handle in the lower right corner of the brush
so you will be able to click it off-screen.

p» Press shift-7 to go to the first cel of the AnimBrush.
p Select the Curve tool if it is not selected.

» Position the brush at the left side of the screen and midway
between the top and bottom.

» Hold down the Alt key and the left mouse button and drag
down to the lower right corner of the screen.

» Release the mouse button and define the third point of the
curve while still holding down the Alf key. When the curve
is a shape you like, click to begin animpainting.

Notice that even though the cube has only two true dimensions,
the combination of the three-sided view and the tumble make it
appear as though the brush is three-dimensional.

This example shows you how to create an animation that simu-
lates the orbit of a planet. This demonstrates the importance of
brush handles—when you rotate a brush, the rotation always
takes place around the brush handle.

\

0 0 i

Figure 7.5 Orbiting planets using brush handle
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Filled Plane Effects

p Select the Brush Selector tool and pick up the ground using
the right mouse button. This will remove the gradient and
leave the primary orange color behind.

» Click the Brush Selector again and pick up the entire picture
as a brush. Click CLR and clear all frames to the orange back-
ground.

» Stamp the picture back down as it was before. Display the
Move requester. Set the X Distance to -320. Set Count to 32.
Click Draw.

» When DeluxePaint is finished drawing your move, press Alt-
x twice to hold your brush by the lower left corner. Position
the cursor in the very bottom right corner of the screen. (This
aligns the left edge of your brush with the right edge of your
picture on frame 1.) Stamp the brush in place. Display the
Move requester and click Draw.

DeluxePaint paints a second version of the DinoBackdrop pic-
ture to complete the 32 frame scrolling background. Play your
scrolling background to see how it looks.

This example showed you how to create a scrolling background
that simulates a camera panning from left to right, but you can
create one that moves in any direction by following the same ba-
sic steps. You can also use a picture that is larger than an anima-
tion frame to create your scrolling background. To do this, you
create a large Spare page and load or paint your large picture.
Then you pick up the pieces of the picture in frame-size chunks
and put them together just as we did above, except that after you
put together two pieces, you go to the Scratch page for the next
chunk of picture and position at the first blank frame (in our case
the first blank frame would be frame 33 if we had additional
frames) and do the same move as before.

The following effects use the Fill option in the Move requester
to create filled planes that move. In the first example, the plane
moves toward you so that jt seems as though you are traveling,
in the second example, the filled plane rolls as though you are
doing a roll in an airplane.

p Set the number of frames to 20.

p Create a simple filled circle brush to use for your filled
planes. (If you are on a 1 megabyte Amiga, don’t add any
gradient or other detail, because these filled plane moves
require a lot of memory even with a simple brush.)
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The Spinning Globe

Figure 7.11 The two color rectangle and the checkerboard

You should now have a rectangle that is white on one side and
red on the other.

» Pick up your rectangle as a brush and create a red and white
checkerboard pattern. Then pick up exactly a 5 square by 5
square section of the checkerboard as a brush.

» Clear the screen. Display the Fill Type requester. Select Brush
Wrap fill.

» Turn on BeSquare in the Prefs menu (so your circle will be
truly a circle). Paint a filled Circle that is approximately 3
inches across.

There it is. Press the Tab key to see the ball cycle. You'll find
more information about color cycling and color ranges in Tuto-
rial Two of Chapter 4, Painting Tutorials.

This example shows you how to create a spinning globe from the

WorldMap picture on your Artl disk. To accomplish this effect,

you create a scrolling background, pick up a section of the back-

ground as an AnimBrush, and use it to animfill a circle using the

Wrap fill type.

< If you are working ori a IMB Amiga, we recommend that you
start this example from a fresh start of the program in Swap
mode (chosen from the initial Screen Format requester). This
fresh start will ensure that you have no memory fragmenta-
tion and Swap mode will give you the most memory to work
with. This example is very memory intensive and may not
work on some 1IMB configurations.
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Spacing Tips

When you animpaint with the shape tools, use the Spacing re-
quester to control the number of brush stamps used to draw the
shape. In effect, this setting determines how many frames you
will paint over.

Instant Marquees: Set the Spacing requester to N Total and the
number of frames you have, and animpaint unfilled shapes
using a built-in brush. Using the Spacing set to N Total for anim-
painting is especially good with the Circle tool, which otherwise
paints a non-cyclical pattern. Also try setting Spacing to Every
Nth Dot, especially with the unfilled Polygon tool.
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DeluxePaint IV’s Reference chapter contains all the information
you’ll need to master the program, arranged in a way that’s easy
to use. The Tools section covers the Toolbox, explaining how to
select, modify and use the tools to draw basic shapes or other-
wise manipulate your image by color, size, shape or orientation.
The Menus section covers all the options available in the pull-
down menus. The menus are described individually, moving left
to right across the Menu Bar, and down through each option.

Some entries in Reference cross-reference other parts of the
manual or other sections of Reference. We recommend that you
look at the cited section for more information about any cross-
referenced entry.

When you start DeluxePaint 1V, the Toolbox appears on the right
side of the screen. It contains built-in brushes, tools, the Color
Indicator, and the Palette.

.

% Select a tool by clicking its icon in the Toolbox.

You can hide the Toolbox to expose more of the painting area by
pressing F10 (this hides the Toolbox and the Menu bar). You can
then press F9 to display the Menu Bar without the Toolbox. Press
F10 to display the Toolbox again.

% Be sure the cursor is not at the top of the screen when you
press F10.

B+
.l

1 l.!! Built-in Brushes

Dotted Freehand
Straight Line
Fill Tool

Unfilled /Filled Rectangle Unfilled/Filled Circle
Unfilled /Filled Ellipse | Unfilled /Filled Polygon
Brush Selector |5 a|#] Text
Grid |EH[# Symmetry
Magnify Zoom

Clear
Current Foreground Color
Current Background Color

Undo Last Painting Action
Color Indicator

Figure 8.1 The Toolbox
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N Total

Every Nth dot

Airbrush

Continuous

Spacing

N Total 20 |
Every Nth dot| ;s
Airbrush 16 |

. e ] Figure 8.4

The Spacing requester

Defines the total number of “splats” that will occur along the
line. You can define the number of “splats” by clicking the edit
box, backspacing or deleting over the existing value, and typing
in the new value. This setting is especially useful for ensuring
that when animpainting over a series of frames you get exactly
the number of brush stamps you need.

Spacing sets the number of pixels between each “splat” of the
brush. This lets you space your brush splats accurately.

Paints using the Airbrush tool along the path defined by any tool
affected by the Spacing requester. The number to the right of the
button sets the number of airbrush sprays to be applied at each
pixel along the path. This creates a fuzzy line or shape. You can
use this feature with the painting modes from the Modes menu
to create interesting effects. For example, using Smear with the
Airbrush spacing can create interesting textured effects on a
colored background.

Figure 8.5 Circle painted using Airbrush spacing and the Color
painting mode

This spacing paints an unbroken path with no space between
pixels. Continuous is the default setting.
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The “spout” of the fill cursor

Holding down i when you click with the Fill cursor, fills outward
to the background color. In other words, the fill spreads outward
until it reaches areas of the current background color.

Holding down the Alt key when you click with the Fill cursor,
animfills the shape. This means that the frames of your anima-
tion will flip, and the fill tool will fill outward on each frame
from the point where you clicked. This option works with all of
the Fill Types except the gradient fills that use the gradient direc-
tion line to define the gradient.

Right-clicking the Fill tool displays the Fill Type requester. The
options in the requester are explained in the following para-
graphs. When you return to the painting screen after choosing a
fill type, the current gradient (or pattern, if Pattern or Perspective
is selected) and its orientation are shown in the Color Fill box in
the Title Bar (see User Feedback in Title Bar, later in this chapter).

Fill Type
' Solid | Brush | Wrap |
Perspective l

Pattern I
From brush |

Range : M | i] &= |
Line | Shap| Cir| Con| Hi|
Dither: == =
Randon __ | NN

Cancell o I Figure 8.7

The Fill Type requester

Fills with the current color. If you paint or fill your shape using
the left button, the shape is filled with the foreground color. If
you paint or fill your shape using the right mouse button, it is
filled with the background color. This is the default mode.

Fills with one image of the current custom brush and sizes it to
fit the filled area. See Figure 8.8.
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Gradients

=] Horizontal paints the gradient horizontally.
@ Vertical paints the gradient vertically with an even distribution.

B Horizontal Line paints the gradient one line at a time and ad-

justs the gradient on each line so that it follows the contours of
the shape being filled.

12

Figure 8.9 Vertical, Horizontal, and Horizontal Line gradient fills

DeluxePaint supports two types of gradients: Linear and Radial.
A Linear gradient fills an object in one direction (in a line), and
can either take the object’s shape into account, or ignore it. A
Radial gradient fills an object in all directions (radially) from

the point where you click, until it reaches the boundaries of the
object. Like Linear gradients, a Radial gradient can either take
the object’s shape into account, or ignore it.

Linear Gradients

The linear gradients are Line and Shap(ed). When you fill an
object with either of these options, a gradient directional line
stretches from the center of the object to the cursor. Use this line
to tell DeluxePaint the direction in which to fill the shape with
the gradient. For example, if you move the directional line to the
top of your shape and click, DeluxePaint fills your shape with
the selected gradient from top to bottom. The first color in the
gradient (in the far left position in the range) appears at the
bottom of the shape.

Line fills the object with a uniform linear gradient, ignoring the
shape of the object.
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112

Figure 8.10 Filling the same shape using different gradient directions

Shaped fills the object with a linear gradient, taking the shape
of the object into account, so gradient lines tend to follow the

object’s contours.

Figure 8.11 Shaped Gradient

Radial Gradients

The radial gradients are Cir(cular), Con(tours), and (Hi)light.
When you select any of them and click on a shape, a gradient di-
rectional line stretches from the center of the object you filled to
the cursor. Move the cursor, which is attached to the directional
line, to the spot where you want the gradient to begin and click.
DeluxePaint will fill your shape radially outward from the point
where you clicked. Radial gradients are especially useful for
drawing shadows and other consistent three dimensional light-
ing effects.
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Random

Dither

Circular fills the object with a circular (shaped) gradient radi-
ating outward from the point where you click. Like the Straight
linear fill, above, Circular does not take the shape of the object
into account.

Contours fills the object with the gradient taking the shape of the
object into account. This creates a contour effect, reminiscent of
topographical maps.

Highlight is similar to Contours, but optimized to create a high-
light effect. Like Contours, the object is filled with its shape taken
into account. See Figure. 8.12 for a comparison between the two
methods.

Figure 8.12 Gradient fill, showing the difference between
Contours and Highlight

When you click the Random action button, a V appears. With
Random turned on, the border between any two colors in the
gradient are randomly mixed (see Ditler, below). Click the ac-
tion button a second time to turn off Random.

DeluxePaint draws patterned gradients by dithering, which re-
duces the contrast between adjacent colors (without changing
the colors themselves). When Random is checked, you can adjust
the degree of color mixing in the gradient fill. Drag the Dither
slider left or right to decrease or increase the amount of dither.
Setting the slider all the way to the left gives almost no mixing
between shades. Moving the slider to the right increases the
amount of mixing at the color boundaries.
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Right-clicking on the Unfilled Rectangle tool displays the Spac-
ing requester. Use this requester to set the spacing between
“splats” in the sides of your rectangle. (See Straight Line Tool,
above.)

Right-clicking on the Filled Rectangle tool displays the Fill Type
requester. Use this requester to set the type of fill you want in
your rectangle. See Fill Tool for an explanation of the options in
this requester.

Unfilled/Filled
Circle

Cerl

Keyboard Equivalent: c—unfilled.
C—filled; mnemonic—circle

Use the Circle tool to paint circles using any brush. The upper
left half of the tool paints a circle outline using the current brush
and the current settings of the Spacing requester. The lower right
half of the tool paints a filled circle using the current settings of
the Fill Type Requester.

» Select the Circle tool, and position the cursor on the page
where you want the center of the circle.

» Drag the cursor in any direction to form the circle. When the
circle is the size you want, release the mouse button.

The circles that DeluxePaint IV paints may not appear perfectly
circular. Circles are painted to be the same number of pixels high
as they are wide. The circles do not appear perfectly circular be-
cause the pixels of the Amiga display are not square. If you want
your circles to appear circular, turn on the Be Square option in
the Prefs menu (see Prefs Menu, below).

Holding down the Ctl key as you paint a circle, causes the circle
to leave “traces” as you paint.

Holding down i as you click on the Filled Circle tool causes the
tool to paint shapes that are filled and then outlined with the
current brush using the settings of the Spacing requester. (See
Freehand Shape Tool for more information).

Right-clicking on the Unfilled Circle tool displays the Spacing
requester. Use this requester to set the spacing between “splats”

in the sides of your circle. (See Straight Line Tool, above.)

Right-clicking on the Filled Circle tool displays the Fill Type re-
quester. Use this requester to set the type of fill you want in your
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To select a polygonal brush:

» Double-click the Brush Selector to select it. The Brush Selector
icon now looks like the Polygon tool.

You can now surround the area you want to pick up as a
brush as though you were drawing with the Polygon tool.
As with the Polygon tool, pressing the space bar completes
the brush selection automatically.

o,
X

Using the left mouse button to pick up a brush simply copies
the selected area as a brush. Using the right button to select
the brush cuts the selected area from the page to make the
brush, and replaces the area with the current background
color.

When you pick up a brush, any colors that match the current
background color are transparent. If you have AutoTransp
turned on in the Prefs menu, this additional rule applies: if all
corners of the brush are of the same color, that color becomes
transparent, regardless of whether it is the background color.
(See AutoTransp in the Prefs menu).

You can retrieve your most recent custom brush or AnimBrush
by right-clicking the Brush Selector or pressing B.

Holding down the Shift key while selecting a brush with the
rectangular Brush Selector will constrain the brush to be a
square. This means that it will be the same number of pixels high
as it is wide. Because the pixels of the Amiga display are not
square, your brush may not appear square. If you want the brush
to appear square, turn on Be Square in the Prefs menu before
you select the brush.

Text

Keyboard Equivalent: t—mnemonic—text. T—text requester

Use the Text tool to add text to your picture.
» Select the Text tool, and move the cursor to the page.

» Click to place the text cursor. Type on the keyboard to enter
text in the current foreground color.

The text will automatically wrap around the right edge of the
page and restart below the original cursor position. If your page
size is larger than the screen, the page scrolls as you type off the
edge of the screen. The text tool does not automatically word-
wrap like a word processor.
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You can use the Backspace key to erase text, and the Return key
to begin a new line. To exit text mode, press ESC or click a paint-
ing tool.

#* You cannot backspace over typed characters if the screen
scrolls.

Right-clicking the Text Tool displays the Choose Font requester.
Use this requester to choose fonts, sizes, and styles for your text.

Choose Font
sapphire ﬂ

swiss
Tines !
fopaz _J

Zack 3

Bold | 1Italic | Underline |
Size:

.

Show |

Drawver [FORLT S Shies == e _soesans)

Cancel | Ok |
Figure 8. 13 The Choose Font requester

The scrolling font list displays the fonts that are available in the
current font directory. To choose a font, click on its name. By
default this directory is specified as FONTS:.

By clicking in the Drawer edit box, typing a new disk directory
path name and hitting Refurn, you can specify a new disk drawer
for fonts. This makes it much easier to access fonts from directo-
ries other than FONTS. For example, to use the fonts on the Art
disk, you would type Art 1 :Karafonts in the Drawer edit box
and press Return.

Choose a size for the font by clicking on the up and down arrows
next to the size edit box. The scrolling list of sizes is restricted to
the currently available sizes for the font that you have chosen.

Choose a style for the font by clicking on the Bold, Italic, and Un-
derline action buttons. You can use these styles in any combina-
tion. Clicking an active (highlighted) button turns it off. The two
fonts included on the Art2 disk have only one size available for
each.
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ASSIGNS Action Button

be used is for the loading of a sequence of pictures as an anima-
tion. If your sequence of Pictures were numbered sequentially or
alphabetically, and started with the word Space and ended with
a .ham extension then you could type Space#?.ham in the Pattern
edit field and only those files would be viewable. Select the first
file, set the # of frames (see below for a more complete explana-
tion of the # of frames edit box) click on load, and your anima-
tion will be put together automatically for you.

The recognized pattern parameters for this edit field are:

? Matches single characters.

#<pattern> Matches occurrences of <pattern>

Examples:

#2 shows all files

#2AH#? shows all files whose name contains the letter A.

AN#? shows all files that begin with the letters AN.

AN#2.27? shows all files that begin with the letters AN and
end with a period followed by a 3 character
extension.

#2.ANIM shows all files that end with a .ANIM extension.

The ASSIGNS button, when clicked, shows you the current
assigns for your system. They are denoted as <ASN> in the file
window, and are blue in color in all but 2 color modes. This func-
tion is beneficial to users with large storage devices, such as hard
disks, removable media, etc. You can create assigns to go directly
into deep levels of subdirectories. For example, if you are work-
ing on a job for XYZ company and your image files are 5 drawer
levels down from your workbench, it will get cumbersome click-
ing through subdirectory after subdirectory to get down to the
images drawer. By placing an assign command in the startup-
sequence of your boot drive, you can avoid this. Please consult
your Amiga owner’s manual or an Amiga DOS manual for more
information regarding editing your startup sequence. The assign
command for the example given above might look like this:

ASSIGN Images: dh0:Graphics/Paint/Jobs/XYZ-CO/
Images

Now from within the program rather than clicking down the 5
levels of drawers you could click the Assigns button and then
click on <ASN> Images: and you are taken directly to the
subdirectory Images.
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The Print Picture requester provides the following options:

Aspect: Specifies the orientation of the picture on the paper,
either Normal, the default, or Sideways. Click the Up-arrow
button for Normal or the Right-arrow button for Sideways.

Image: Specifies whether the printout will be a positive or nega-
tive image. Click the Plus button for positive or the Minus button
for negative.

Shade: Specifies whether the printout will be in color, in shades
of gray, or in black and white. Make sure the setting is appropri-
ate for your printer. If you are using a single-color ribbon, click B
& W. If you want to translate your image’s colors into shades of
gray, use the Gray setting. To print in full color, click Color.

% For your pjcture to print out correctly in the B&W or Gray
settings, your palette should contain black, white, and a
number of grays.

Placement: Specifies whether the picture should be printed
against the left margin of the page or centered on the page.

%/Dots: Controls the size of the printout by specifying the %
width and % height of the printout paper. The Dots option lets
you specify the size of the printout in terms of the actual printer
pixels.

If the % option is active then the following parameters can be
specified:

% Wide and % High: These let you change the aspect ratio (the
ratio of height to width) of the picture by setting the percentages
for each. The default values are 100% Wide and 0% High. 0% is

a special case and tells the printer to maintain the same aspect ra-
tio as the screen version of the picture. To change the aspect ratio,
leave the % Wide at 100 and enter a new % High value.

You can use this feature to compensate for elongated squares and
circles that result when you change screen formats. If you just
want to shrink the picture while maintaining the same aspect ra-
tio, change the % Wide value and leave the % High value at 0. To
change either value, click the appropriate gadget, Backspace or
Delete over the existing value, and type in the new one.

If the Dots option is active you can set only the printout width
and height in dots.
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Show Page

Screen Format ...

Full Page gives you a full printed page image (8 1/2 by 11
inches) on most printers. Overscan presents a full-screen display,
which lets you create pictures that fill the entire screen. This is
particularly useful if you wish to videotape your images. In or-
der to paint on the edges of a full video screen, you need to scroll
the image around using the cursor keys or the n key unless you
set the screen format to Overscan (see Screen Format, below). Al-
ternatively, you can view the entire screen by selecting Show
Page, below.

Clicking one of the three settings automatically sets the height
and width in the corresponding edit boxes. You can also type in
any other size you wish by clicking the appropriate edit field,
Backspacing or Deleting over the existing value, and typing in
the new size. Although DeluxePaint will recognize page sizes up
to 1008 x 1024, you would need to reduce the number of colors in
your palette to create a picture this large.

Keyboard Equivalent: S

Hides the Toolbox and Title Bar, and displays the entire docu-
ment, if necessary in a reduced format. For example, in 640 x 400
page size in Lo-Res, it shows only every other pixel. If the page is
oversized (larger than the screen), you can move the rectangle to
view a different area of the screen by holding down the left
mouse button; dragging the rectangle to the area you want to
view; and releasing the mouse button. You are returned to the
current page with the area of the rectangle in view. Pressing any
key returns you to the current page without repositioning the
view.

For more exact positioning of the rectangle, you can move it with
the arrow keys. The arrow keys move the rectangle one unit at a
time. (A unit is the page size dimension divided by the screen
size. So with 320x200 screen format with 640x400 page, the rect-
angle moves 2 pixels at a time.) Holding down the Alt key and
pressing the arrow keys moves the rectangle in screen size incre-
ments.

Displays the Screen Format requester. If you select a number of
colors that will exceed your available memory, DeluxePaint will
retain the format you have selected but use fewer colors. Be sure
to save a copy of your current screen before changing screen for-
mats, because once you have reduced the number of colors, the
original color information is lost. In addition, note that changing
formats eliminates most items from memory, including the Font
Directory.
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Handle p

Center

Corner

Place

Lets you specify whether the cursor holds a custom brush by its
center (the default), by one of its four corners, or by an offset po-
sition, which you can define. Use the keyboard equivalents to ad-
just your brush handle when you need to move your cursor
without moving the brush. You can move the brush handle with
the mouse button down this way.

Keyboard Equivalent: Alt-s
Positions the arrow cursor, which represents the handle, at the
center of the brush. This is the default position.

Keyboard Equivalent: Alt-x and Alt-y

Positions the arrow cursor, which represents the handle, at one
of the four corners of the brush. If you have a custom brush cur-
rently held at the center, selecting Corner moves the arrow cursor
to the lower right corner of the brush. Use Alt-x to toggle be-
tween the lower corners. Use Alt-y to move the handle to the

top of the brush and toggle between the upper corners.

The location of the arrow cursor the next time you pick up a
brush depends on the direction you drag the mouse when you
pick up the brush. If you drag down and to the right, the cursor
will remain at the lower right. If you drag up and to the left, the
cursor will move to the top left. The same principle applies if you
drag down and to the left or up and to the right. In other words,
the corner you drag to is the one to which the arrow cursor will
attach.

Corner is particularly useful in Perspective mode (see the Effect
menu, below).

Keyboard Equivalent: Alt-z

Lets you position the brush handle at any position relative to the
brush. To place the handle, pick up your brush. Choose Handle>
Place. Drag in any direction to offset the cursor from the brush.
When you release the mouse button, the cursor will hold the
brush as you specified.
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For example, if you have 10 frames, and you want a brush to ro-
tate 360 degrees over the 10 frames to make it look as though it is
spinning when you play the animation, you would turn Cyclic
on. DeluxePaint IV would calculate the rotation to end on the
11th frame (which in this case would be the 1st frame). The result
is that the brush is not rotated to a full 360 degrees on Frame 10.
Instead, the brush reaches 360 degrees on Frame 1. DeluxePaint
doesn’t paint the brush on the last frame, since it’s position
would normally be the same as your original frame, but it does
move forward to that frame and positions the brush in the event
that you want to click it down.

Ease-Out: Set the number of frames over which you want the
brush motion to gradually accelerate.

Ease-In: Set the number of frames over which you want the
brush motion to gradually decelerate.

Count: Set the number of times the brush is painted to complete
the total movement and rotation as specified by the dist and
angle edit boxes.

Direction: The Direction action buttons control the direction of
your move and the order in which the frames of the animation
are painted.

Move lets you choose to have a move drawn in one of two ways.

Go From starts the movement of the brush from the point where
you stamped your brush (indicated by the large dot) and paints
forward.

Come To starts the animation at an earlier frame and moves the
brush forward to the point where you stamped your brush.

Record lets you choose the order in which the frames of the
brush move are painted. These buttons are available only if you
have more than one animation frame (see Figure 6.6).

Forward paints the move by stepping forward from the point
where you stamped your brush. This is the default setting and
the one you will use most often.

In Place paints all of the move on the current frame.

Backward paints the move in reverse order by advancing to the

last frame and painting backwards. This option is useful when
you are using Trails.
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Add Frames . .

Copy Frames . .

Delete Frames . .

Control

Panel On/Off

Set Frane Count
Count: | N

Figure 8.30
Cancel Ok
J | Set Frame Count requester

Displays a requester that lets you add any number of frames af-
ter the current frame. DeluxePaint copies the contents of the cur-
rent frame to the added frames, and makes the last new frame
the current one.

Keyboard Equivalent: Click on the + icon in the Animation Con-
trol Panel. Alt-= will automatically add a single frame to the ani-
mation.

Displays a requester that lets you copy the current frame to a
range of frames or to all the frames in your animation sequence.
Use the Insert Before Frame edit box to place the copied range of
frames in your animation.

Copy

Current Frane to
Range | ioummmmm  fo LY

All Franes

Range | NN fo |¥: NN
Insert Before Framne! | S

Cancel I

Figure 8.31 Copy frames requester

Displays a requester that lets you delete the current frame, a
range of frames or all frames in your animation sequence. If you
delete the current frame, DeluxePaint makes the following frame
the current frame unless you are already at the last frame.

Keyboard Equivalent: Click on the - icon in the Animation
Control Panel.

Control displays a submenu of options for moving around in
your animation frames and for playing the animation.

Keyboard Equivalent: Alt-a
Displays the DeluxePaint Animation Control Panel. It contains
a Frame Counter scroll bar and 15 control buttons for working

through and playing your animations. Click an option on the
Panel to select it.
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If you want to delete only one color, click on that color in the
color set. The color will be deleted and the slot it occupied in
the color set will be empty.

If you want to delete more than one color, a range for ex-
ample, click the first color in the range; click DELETE; move
the TO cursor to the last color in the range; and click the
color. DeluxePaint will delete all colors between the selected
color in the sample-color box and the color you clicked on.

MHPO] You can reverse the last change you made in the Color Mixer by

clicking UNDO.

You can clear the changes you made in the Color Mixer by click-
ing REVERT. With the exception of the mixing area, this returns
the requester to the condition it was in before you displayed the
Mixer.

Color Mixing Area

Use the mixing area to interactively mix colors to create new
ones, and, if you wish, add colors to your palette. You can use
colors in the picture, colors from the palette, and colors you mix
to create new shades. Using your current built-in or custom
brush you can select colors from the palette (one at a time), paint
with them in the mixing area, and mix them with other colors.

Creating a New Color
You can create a new color in the Mixing Area in two basic ways:

1. Mix a selected color in the mixing area with one or more
other selected colors. The resulting color can be a new color.

2. Edit a color by adjusting its values with the RGB/HSV
sliders.

Here's a step-by-step example of how to select a color from
the current picture, edit it, mix it with another color, and add
it to the palette.

Selecting a Color

» With a picture on your screen and the Color Mixer exposed,
click the PICK action button.

» Move the PICK cursor to the picture and click on a color.

The color you clicked on automatically becomes the current
foreground color. It appears in the sample-color box, so you
can paint with it immediately. The color slot of the new color
appears indented in the color set.
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Arrange

Use Brush Palette

This color can be edited. To edit the color in the mixing area:

» Drag one or more of the RGB/HSV sliders to change the color
values, which changes the color itself.

Mixing a Color
» Click a medium sized built-in brush and paint in the mixing
area.

» Choose another color, and paint over the first color in the
mixing area. As you combine the two colors, new shades are
created. You can repeat this step as often as you like.

» When you have created a color you want to use, click the slot
in the color set where you want to place the new color.

» Click the PICK button; click the color in the mixing area to
make that shade the new color.

Clearing the Mixing Area

You can clear the Mixing Area to any color by copying the color
to it. Here's how:

» Select the color you want to clear the Mixing Area to.
» Click COPY. TO appears attached to the cursor.

» Click the in the Mixing Area. It is cleared to the color you
selected.

Keyboard Equivalent: P

Shows the Arrange requester. It displays all 256 colors of a Color
Set (4 rows [128 colors] at a time). Clicking on the up and down
arrows scrolls through the color set one row at a time (32 colors
in a row). Shift-clicking on an arrow scrolls 4 rows at a time.
Arrange is helpful if you want to copy, exchange or spread colors
over more than one row at a time. The Arrange requester will
replace the Color Mixer if it is open.

Use the Arrange requester to organize colors in your palette or
delete colors. It lets you delete colors easily, so that new colors
can be added to the current 256-color set.

The action buttons in the Arrange requester work exactly as they
do in the Color Mixer. See above.

When you load a brush from disk, DeluxePaint continues to use
the current picture palette, even though it may be different from
the one the brush was created with. Use Brush Palette switches
to the brush palette, and includes any information about color
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Bg<->Fg

Remap

Recompute

Brush p

Bg ->Fg

Bg<->Fg

QO

< Undo does not reverse this change.

Swaps all pixels in the current background color with the current
foreground color. This is similar to the Bg->Fg option above, ex-
cept that the change occurs in both directions. The change occurs
on-screen only and does not affect the order of colors in the color
palette.

% Undo does not reverse this change.

When you create a picture, DeluxePaint “remembers” each color
on the screen by remembering its location in the palette. If a
picture on the screen was created with a palette other than the
current palette (for example, if you have modified the palette
since loading the picture), Remap finds the locations in the cur-
rent palette of the colors it used in the original palette and tells
the picture to look there for its colors. Bg->Fg and Bg<-> Fg,
above, are special cases of Remap. See also Remap under the
Brush option of the Color menu, below.

% Undo does not reverse this change.

This option is available in HAM mode only. Choosing this option
recomptites the picture data by doing a remap with the current
palette. If you have loaded a HAM image from a different pro-
gram, Recompute may reduce the fringing effects you see when
moving a brush across the screen.

Use the options in the submenu to modify the current brush
colors.

Changes all pixels in the brush that are in the current back-
ground color into the current foreground color. This provides an
easy method of making a global color change — all instances of
the background color in the brush are changed to the current
foreground color. Because you can select any color in the brush
as either the foreground or the background color at any time, you
can make intricate color changes easily. This operation affects the
brush colors only and does not affect the picture or the order of
colors in the palette.

Swaps the current background color in the brush with the cur-
rent foreground color. This is similar to the Bg->Fg option, except
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Remake

Paint

Reverse

On/Off

Free

Load ...

When you have a stencil active and you apply colors to your
picture, the colors you apply are not protected, even though they
may be locked in the Make Stencil requester. You can lock newly
applied colors by bringing up the Make Stencil requester and
clicking Make, or by selecting Remake from the Stencil
submenu.

% If you have several animation frames and you make a stencil,
DeluxePaint automatically remakes the stencil as you move
from one screen to the next.

Keyboard Equivalent: Ctrl-s

Uses your current built-in or custom brush to paint the area you
want stenciled. The image under the stencil will be displayed in
a “half-tone” mode. When you’ve finished painting the stencil,
choose Paint again to exit this mode and activate the stencil.
Stencils you create using Stencil Paint are “area-based” and
apply only to the current picture or frame. Also, if you choose
Make or Remake to create a “color-based” stencil, your painted
stencil is discarded.

Has the same effect as clicking Invert in the Make Stencil
requester (see Make, above).

Keyboard Equivalent: * (below Esc)
Toggles the stencil on and off. This maintains the stencil but
turns it off temporarily so you can paint on the protected colors.

Creating a stencil uses memory, even though you may have it
turned off (see On/Off, above). Free deletes the stencil and
deallocates the memory it was using.

Stencils can be loaded as separate items. They are full screen
only, and can be loaded only to the position they occupied when
they were created. In other words, you cannot create a page
larger than screen size and load the stencil into the middle of the
page. The Load requester works like all other Load requesters in
the program (see Load in the Picture menu).

% When you load (or save) a stencil, you are loading (or saving)
only a layer of data that indicates which pixels in your pic-
ture you can or cannot paint on . You are not loading settings
for the Make Stencil requester. In other words, stencils you
load are area-based, like the stencils you create in the Stencil>
Paint mode. Area-based stencils do not apply across ani-
mation frames and are replaced by color based stencils you
subsequently create using the Make Stencil requester.
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Save ...

LightTable p

On/Off

Merge

Dim

Two Back

Previous

Next

Warning!

You can save stencils just as you can any other file, such as pic-
tures or brushes. The Save requester for stencils works like all
other Save requesters in the program (see Save in the Picture
menu). See the note above regarding the nature of the data you
are saving when you save a stencil.

Keyboard Equivalent: |

Turns the LightTable on or off. The LightTable lets you see the
animation frames that immediately precede and /or immediately
follow the current frame (or the spare page), which gives you
greater control while creating your animation. This effect simu-
lates the “onion skin” techniques used by traditional animation
artists. By using a combination of LightTable options, you can see
a maximum of four frames simulataneously (Next, current frame,
Two Back).

The lighttabled frames appear behind the current image (in the
BG color area) and can be dimmed to a darker color in all screen
format modes except HAM.

Merges all of the currently viewed images into the current frame,
and turns off the LightTable so you can see the result as it actu-
ally appears.

,

% You cannot UNDO this Merge command.

Keyboard Equivalent: Alt-1

When Dim is on, all frames displayed on the LightTable, except
the current frame, appear dimmed. You can easily see at a glance,
which frame you are working on. Dim is on by default. This op-
tion applies to all screen format modes except HAM.

% If you dim a frame that contains very dark colors, those colors
may be difficult to see.

Shows/hides the frame that is two back from the current frame
in the LightTable. For example, if your current frame is number

3, then Two Back shows frame 1 on the LightTable.

Shows/hides the frame immediately preceeding the current
frame in the LightTable.

Shows/hides the frame immediately following the current frame
in the LightTable.
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Spare

Background p

Fix

Free

Lock FG

Anti-alias p

None, Low, High

Shows/hides the scratch page in the LightTable.

Fixes the background by “locking” the current picture. This
allows you to draw on it without losing any of the background.
You can erase any paint you apply after fixing the background
by clicking CLR or by painting with the right mouse button.

% Fixing the background uses additional memory. When the
background is fixed, no colors may be picked up from that
background.

This “unlocks” the background, and merges it with anything that
was painted over it, so that clicking CLR will clear the entire pic-
ture. It also frees up the memory that was allocated to fixing the
background.

The Make Stencil requester lets you create stencils based on col-
ors in the palette. By locking a color, you make it impossible to
paint on that color, wherever it may be on the page. By using a
combination of Fix Background (see above) and Lock FG, how-
ever, you can define a stencil by area rather than color. When you
select Lock FG, you define as a stencil those areas on the page
that you have painted since fixing the background, regardless of
the color of those areas.

Anti-aliasing is a smoothing process which eliminates or reduces
the jagged edges apparent in lines that aren’t precisely vertical or
horizontal. The effectiveness of anti-aliasing is dependent on the
range of colors in the palette. For example, to draw a smooth, ob-
lique black line on a white background, you’ll need to have two
intermediate shades of gray in the palette.

Anti-aliasing works with straight and curved lines, and with
filled and unfilled shapes, It is especially good at smoothing the
jagged lines in a brush that result from rotating or shrinking it in
Perspective mode.

Keyboard Equivalent: Alt-/

Set the level of anti-aliasing used on your brush when you paint.
None is the default setting and applies no anti-aliasing. Low lets
you eliminate some of the jagged outline in your images and
brushes. The cost of removing jagged lines is painting speed,
but it is still faster than smoothing out an image by hand. To use
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Perspective )

S
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FillScreen

Reset

Center

ground color. For instance, in the above example if the translu-
cency level was set to 75%, the resulting color would be 75% of
the existing color in the painting, red, and 25% of the foreground
color, blue. The RGB value of the resulting color would be R:11
G:0 B:3.

Translucency works with all the painting tools (except text, single
pixel Airbrush, or the 3- and 5-pixel built-in brushes), and in
combination with the Process options. By combining Translu-
cency with Tint, for example, you can control the degree of
tinting.

The Perspective submenu contains options for manipulating a
brush in three dimensions.

Keyboard Equivalent: Enter (on keypad)

Puts you into Perspective mode. Your brush is represented by a
four-cell matrix, which you can manipulate with keypad com-
mands (listed later in this section). The amount of rotation for
axes x, y, and z is given in degrees on the right side of the Title
bar. The center of perspective (see Center, below) is indicated by
a cross-hair. You can paint an image of the rotated brush at any
time by clicking.

% To exit Perspective mode, click a tool in the toolbox.

Keyboard Equivalent: - (minus on keypad)

Fills the screen with the current brush, in its current state of rota-
tion in 3D. The entire brush size (not just the opaque part) is the
default size for the Perspective Fill pattern.

Keyboard Equivalent: 0 (on keypad)

Resets the brush to its original state before rotation, and returns
all of the settings in the Perspective Settings requester to their
defaults (see Settings, below).

< Note: The keyboard equivalent does not reset the perspective
center. It is useful if you need to reset your brush to its origi-
nal orientation without changing your perspective plane.

Keyboard Equivalent: . (period on keypad)
Allows you to set the Perspective center or horizon in your

perspective “landscape.”

< When you select Center, your cursor changes into a large
cross-hair. The smaller, stationary cross-hair on the screen
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Settings

Grid

From Brush

Angle Step

Screen

indicates the existing center. Move the large cross-hair to the
new center you want and click either mouse button.

Once you have set the Perspective center, the position of the
unrotated brush relative to that center determines the position of
the perspective plane when you rotate the brush. The greater the
distance above or below Perspective center, the less pronounced
the perspective effect.

Displays the Perspective requester. When you are in Perspective
mode, you can also display this requester by right-clicking the
Grid tool.

Perspective
X e Z
Grid: EEE 83 ST

From brush
Angle Step: J

X -
Display: Pos | Fi 339
igure 8.
O
_Cancel | __Ok | Perspective requester

The following options are available:

You can use these edit boxes to set the dimensions for a grid in
three-dimensional space. When you first open the requester, the
numbers in these boxes correspond to the dimensions of your
brush; the Z dimension automatically takes the same value as the
Y dimension. It is important to remember that the entire brush
size (not just the opaque part) is the default size for Perspective
Grid and Perspective Fill.

Clicking From Brush sets the X and Y grid values to correspond
to the width and height of the brush. This is the quickest way to
restore the perspective grid settings to the same dimensions as
your brush without affecting any other settings.

Specities the rotation increment used in conjunction with the
Shift key and the appropriate keyboard rotation key (see
Perspective Rotations, below). This value defaults to 90°.

The default setting, uses the screen coordinate system when ro-
tating the brush on the X, Y, and Z axes. (If you are familiar with
coordinate systems, you will know this coordinate system as the
Euler method, which measures all three angles of rotation from
absolute zero.)
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Other Perspective
Keyboard Commands
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Pressing Keypad 0 resets all three axes to zero and fixes the Z
axis (see below), but retains the apparent distance settings. Press-
ing Keypad 0 in conjunction with the Shift key resets all perspec-
tive values to the default state.

Ctrl temporarily fixes the Y axis so that you can move the brush
forward or backward in 3D space by moving the mouse forward
or backward.

The ; and “ keys move the brush plane forward or back along its
fixed axis (see below) without changing its orientation, moving it
in a direction perpendicular to the brush plane. This is the same
effect described in the above discussion on brush position prior
to rotation. Thus, with the Z axis fixed, brush position relative to
the Perspective center at the moment of rotation determines the
brush’s distance above or below eye level. You can achieve the
same effect after the brush is rotated by using the ; and * keys to
move it forward or back along its Z axis.

Pressing these keys with the Shift key held down results in larger
increments of movement. In addition, you can modify the appar-
ent distance from the observer by pressing the < and > keys (i.e.,
the Shifted ”“,” and “.” keys). Thus, when the apparent distance is
great, the perspective foreshortening is at a minimum, becoming
greater as apparent distance decreases.

Fixing Axes: Whenever you start in Perspective mode, the Z
axis (the one perpendicular to the screen) is “fixed,” that is,
the mouse does not move the brush through that axis. You can
selectively fix any axis, as follows:

To fix the X axis, press Shift-9
To fix the Y axis, press Shift-6
To fix the Z axis, press Shift-3

As noted above, you can move along the axis that is currently
fixed by using the Shifted or un-Shifted ; and * keys (use the
Shifted keys for larger increments). You can also temporarily fix
the Y axis by holding down the Ctrl key.
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Prefs Pref s

Coords
Menu Fast FB
MultiCycle

v Horkbench
ExciBrush
AutoTrans
No Icons

v AutoGrid
OriginUL

o Fastad jeesr

Be Square

P

1

Customizing
the Prefs Menu

Coords

The Prefs menu contains a list of options that you can toggle on
or off to suit your work habits. When you choose an option, a
check mark (V) appears to the left of the option to indicate that
it’s turned on. Choosing the option again turns the option off
and removes the V.

You can toggle multiple options by clicking on the option while
the Prefs menu is exposed.

The AutoGrid is turned on by default for all DeluxePaint users.
For artists using HAM screen format, FastAdjust is also turned
on by default.

You can customize your working copy of DeluxePaint so that the
preferences are automatically set to the way you like them each
time you start the program. For example, you might like to have
Coords always turned on when you boot DeluxePaint. To cus-
tomize the preferences, use the Tool Types feature of Info in the
Amiga Workbench. Here’s how to do it under Workbench 1.3.

» Boot your Amiga. Insert your working copy of the program
disk. Click the DeluxePaint program icon to select. Choose
Info from the Workbench menu.

The Info requester appears. In the bottom half of this requester
you’ll see a box for Tool Types with ADD and DEL buttons. To
turn a Prefs option on:

» Click the ADD button. Type the name of the Prefs option you
want to turn on automatically each time you boot the pro-
gram. (Type it exactly as it appears in the Prefs menu.) Press
Return.

To turn a Prefs option off, scroll to display that preference name
in the edit box and click DEL.

» Click Save to exit the Info requester and save your changes.

Keyboard Equivalent: Shift-\

This option turns on the coordinate display in the upper right-
hand portion of the Title Bar. Simply moving the mouse displays
the current position of the cursor, with the origin (0, 0) set to the
lower left corner of the screen. Holding down either mouse but-
ton temporarily resets the origin to the current cursor position
and displays the displacement value from that temporary origin
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Fast FB

MultiCycle

Be Square

Workbench

ExclBrush

as you move around the screen. The readout is scaled in pixels.
See also OriginUL, below.

Fast feedback. Turn on Fast FB when working with large or com-
plicated brushes while using the line or unfilled shape tools. Fast
FB lets you draw your lines or shapes using the smallest (one-
pixel) brush for feedback, and then completes the design using
the currently selected brush. This increases response speed while
you are drawing, but does not affect the final image.

Works in conjunction with the Cycle paint mode from the Mode
menu. With MultiCycle turned on, painting with a multicolored
brush in Cycle mode cycles each color in the brush, provided the
color is in a cycle range. When MultiCycle is turned off (the de-
fault), using Cycle with a multicolored brush treats the brush as
though it were a single color (the current foreground color).

Because the Amiga’s pixels are not perfectly square, circles and
squares drawn with the shape tools are not perfectly round or
square. If you wish to draw “true” circles or squares, select Be
Square. This will square all the built-in brushes, the appropriate
shape tools, and symmetry. Be Square does not square gridding
or perspective, and should be turned off when you are using
those features.

Toggles the Amiga Workbench on and off. Default setting is off.

If you pick up a brush with ExclBrush (and the Grid) selected,
you will exclude a one-pixel border on the right and bottom
edges of your brush (see Figure 30). This is useful if your brush
has a colored border around it and you want to use the brush to
create a pattern fill or perspective fill (using the Fill Type re-
quester). When DeluxePaint creates your pattern, the border will
be uniform throughout instead of being twice as wide where one
copy of the brush is placed next to another.

% ExclBrush has no effect on brush pickup when the Grid is off.
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AutoTransp

No Icons

AutoGrid

The image The image
picked up picked up
with Excl with Excl
Brush off Brush on

Figure 8.42 An example of using ExclBrush

Modifies the way brush pickup works. With AutoTransp turned
on, Deluxel’aint determines the transparent color by looking at
the corners of the captured rectangle or the points of the polygon
to see if they are the same color. If the four corners are the same
color, that color becomes the transparent color, otherwise the
current background color remains the transparent color.

When No Icons is on, your files are saved without the icon “info”
files. This option is useful if you don’t ever expect to launch an
application by double-clicking on a picture file. Saving without
the icons saves space on your disks.

With AutoGrid turned on, the perspective grid is resized auto-
matically to match any custom brush you choose to load or pick
up. It's as if you had clicked the From Brush action button in the
Perspective requester. When AutoGrid is off, the perspective grid
is not automatically resized.

* This option affects only the grid in Perspective, not the stan-
dard grid.

265  Reference DeluxePaint 1V






Axis Rotation

Coordinates

Memory Availability

P Appears in the middle of the Title Bar when you have se-
lected one of the Process options (Tint, Hue, Value) from the
Effect menu. Process>None does not display the P.

S Appears in the middle of the Title Bar to show a Stencil is
active.

s Appears in the middle of the Title Bar when a Stencil is active,
and Stencil>Show or Stencil>Paint is selected.

T Appears in the middle of the Title Bar when Translucency
from the Effect menu is turned on.

When you are in Perspective mode, the rotation of the selected
shape about each axis (x, y, and z, respectively) appears in the
right corner of the Title Bar. The axis rotation information is
superseded by the cursor coordinates if you turn on Coordinates
in the Prefs menu.

When Coords is active, the coordinates of the cursor position are
displayed in the right corner of the Title Bar.

Press the Ctrl key and the letter a at the same time to display
available Fast memory/Chip memory in the left corner of the
Title Bar. See Appendix A for information on DeluxePaint’s
memory usage.
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Color Controls

Ctrl-r Range requester

Alt-r Reverse direction of range

Alt-] and

Alt-[ Step forward/backward through available ranges

Alt-t Translucency On/Off

Ctrl-t Translucency Setting requester
Alt-p Process On/Off (Tint is default)

P Color Mixer requester

P Arrange Palette requester
Perspective Enter Enter/Exit perspective mode
Commands Keypad 7 and 8 Rotate about the X axis

Shift Keypad 7 and 8 Rotate X axis by Angle Step

Keypad 9: Reset X axis to 0°
Keypad 4 and 5

Shift Keypad 4 and 5
Keypad 6: Reset Y axis to 0°
Keypad 1 and 2

Shift Keypad 1 and 2
Keypad 3: Reset Z axis to 0°
Keypad 0 Reset all axes to 0°
Shift Keypad 0

Shift Keypad 9
Shift Keypad 6
Shift Keypad 3
Keypad “-” (Minus)

Keypad “.” (Period)
;and ‘ keys:

Shift ; and “ keys (: and “)
< (Shift .) and > (Shift ,)

Ctrl
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Rotate about the Y axis
Rotate Y axis by Angle Step

Rotate about the Z axis
Rotate Z axis by Angle Step

Reset all axes, positions, and
settings

Fix X axis

Fix Y axis

Fix Z axis

Fill the screen with the current
brush at the current perspective
Reset Center

Moves the brush along its fixed
axis in a direction perpendicular
to its plane

Same as ; and ‘ keys but with
greater increment

Modify observer distance from
screen

Temporarily fixes the Y axis so
you can move your brush on the
x and z coordinates

Toggle Angle/Position display
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Appendix C: The Player Utility

The Player utility on the Art2 disk lets you play the animations
you have created with DeluxePaint [V. You can boot the utility
from the Workbench or use CLI arguments to start the Player.

From the Workbench, open the Art2 disk and double-click on the
Player icon. This loads the program in the default screen format
(lo-res, 320 x 200, with 32 colors). The screen is black and the
Menu Bar is not displayed. To see the utility’s single menu, move
the pointer to the upper left part of the screen and press the right
mouse button. Animate appears in the Menu Bar, and the menu
options, Load, Play, About, and Quit descend below it.

Choose Load and when the Load Anim requester appears,
specify which drive you want to make active and then load a
picture or anim from the directory of the drive you chose. The
utility automatically plays the highlighted file when you click
Load in the requester. If you want to replay the animation after
you have stopped it, choose Play. About displays the version
and date of the utility. To exit the Player and return to the
Workbench, choose Quit.

You can use the same keyboard commands you’ve used in
DeluxePaint IV while you view your animation.

KEY EFFECT

Tab Turns color cycling on/off
Left Arrow Slows down play rate
Right Arrow Speeds up play rate

r Reverses play direction
Esc or Space bar Stops plays

1 Go to previous frame

2 Go to next frame

4 Play the animation

5 Play once

(o2}

Play ping-pong

To use Player from the CLI or Shell, open the CLI or Shell from
the Workbench. On the command line type cd Art2: and press
return.

< If Art2 is not loaded you will be prompted to insert it.

This will change the current directory to the Art2 disk where the
Player utility is located. At the next prompt, type player (add a
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Appendix D: Amiga Display Modes

DeluxePaint IV supports all of the built-in Amiga graphic display
modes — low resolution, high resolution, extra-halfbrite, and
hold and modify. You don’t need to know much about the dif-
ferent display modes to create great art with DeluxePaint IV.

But some understanding of how the display modes work, and in
particular, how they affect the number of colors available in the
palette, can help you work more effectively.

This appendix explains how a pixel derives its color, and how the
display mode and the number of bit planes determine the num-
ber of colors available in the palette. We've tried to avoid overly
technical explanations, but the material is still very technical. If
you don’t understand everything you read here, don’t be dis-
couraged, just remember that you don’t really need to know this.

What Is a Bit Plane?

A bit plane can be thought of as a flat grid of dots — a plane of
dots, where each dot represents a bit. So when we say “bit,”
think dot.

If you look ahead to Figure D-1, you'll see that we drew the bit
planes as flat surfaces. The best way to think of this surface is as
a flat grid behind your computer screen. (This isn't actually how
it works, but it may help you visualize how the colors are as-
signed to pixels.) The grid is the same dimensions as your screen
resolution. For example, if your screen is 320 pixels wide and 200
pixels high, each bit plane is also 320 x 200 bits.

Bit Planes and
Awvailable Colors

Now imagine that each dot is either filled in or it’s not. If the dot
is filled in, it has a value of 1 and is said to be “on.” If it is not
filled in, the dot has a value of 0 and is said to be “off.” In the
simplest case of a display mode with only one bit plane, the
picture can have only two colors. A pixel is one color if its cor-
responding bit is on or a different color if the bit is off.

The bit planes themselves don’t determine the color of the pixel,
they simply determine which color register the pixel looks to for
its color. With a single bit plane, the pixel points to either Color 0
or Color 1. If you add another bit plane behind the first, the num-
ber of possible color registers doubles to four. Each additional bit
plane doubles the number of colors again. The color register con-
tains the numbers for the amount of red, green, and blue in the
color.
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Extra-Halfbrite
Display Mode

Hold And Modify mode is a departure from the notion that each
additional bit plane doubles the number of colors available. Hold
and Modify is a special case that we'll explain in a moment.

Graphics Mode
320x200 | 320x400 | 640x200 | 640x400
1 2 2 2 2
w
2
s 2 4 “ 4 4
a4l 3 8 8 8 8
=
5| 4 16 16 16 16
é 5 32 30 n/a n/a
2| 6 | 64/4006 | 6474096 n/a n/a

Figure D-2 Number of Colors in Each Display Mode

Extra-Halfbrite uses a trick to increase the number of colors

available on the screen. The Amiga supports only 32 color reg-

isters directly, but Extra-Halfbrite uses a sixth bit plane to indi-

cate an additional 32 registers that don’t really exist. The first 32

registers are standard color registers; the second 32 are halfbrite

equivalents. Pixels that use halfbrite colors point to one of the
standard color registers and indicate that the color should be dis-

played at half its normal intensity. This means that the second 32

pixels are not independant of the first 32; you can change the

color values only in the first 32 registers, and the change is auto-
matically reflected in the halfbrite equivalent. Figure B.3 shows
how Extra-Halfbrite uses the bit planes and color registers.

% Not all Amiga 1000 computers support Extra-Halfbrite. The
easiest way to find out whether or not your computer sup-
ports this display mode is to try it. Open an Extra-Halfbrite
screen and look at the Palette (make sure the pointer is not in
the Menu Bar or Toolbox). If the last 32 colors are the same as
the first 32, your computer doesn’t support Extra-Halfbrite.
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Bit-Plane 5
¥ Bit-Plane ¢
- Bit-Plane 3
Bit-Plane 2
Bit-Plane 1
3 Bit-Plane 0
Q\ Color Palette Registers
| Color Register 0 Color Register 32 —|

Color Register 1 Color Register 33
Color Register 2 Color Register 34
Color Register 3 Color Register 35
Color Register 4 Color Register 36
Color Register § Color Register 37
Color Register 6 Color Register 38
Color Register 7 Color Register 39

[\/\M/L\NMW\/\[\MWNN\/

32 Color Register 29 Color Register 61 =1
ﬂ |/Color Register 30 Color Register 62
| color Register 31 Color Register 63

Hold and Modify
Display Mode

Figure D-3 Amiga Extra-Halfbrite Pixel Color Selection

Hold and Modify display mode uses only 16 color registers, but
manages to display all 4,096 colors on the screen at the same
time. To accomplish this, HAM display mode uses the first four
bit planes to address the 16 color registers, and uses the fifth and
sixth bit plane to determine whether the register color ora HAM
color should be used.

A HAM color is formed by taking the RGB value of the preced-
ing pixel on the screen, and substituting a new value for one of
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Because HHAM colors are based on color values of the preceding
pixel, and only one color value can be changed at one time, it
may take three pixels to reach the color you really wanted. In
Figure D-5 it takes three pixels to change black (R0, GO0, BO) to
white (R15, G15, B15). Note that this example assumes there are
no intermediate colors in the normal color registers. This gradual
change from one color to the next is sometimes referred to as
“ramping” the color, and appears on the screen to the left of
HAM pixels. If you need fine details in your picture, you will
want to use a color from the color registers, because those colors
do not require ramping.

Black (0, 0, 0) Green (0,15,0) Yellow (15,15,0) White (15, 15, 15)

= — o]

Figure D-5 HAM Color Ramping

In DeluxePaint 1V, if you hold a brush over an area made up of

HAM pixels, you may see an effect called “fringing.” The fring-
ing appears as streaks running to the right from the edge of the
brush. This effect is only temporary. When you paint the brush

onto the picture, DeluxePaint corrects the fringing, but you may
see the “ramping” effect where DeluxePaint recreates the HAM
color to the right of your brush.
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Notes



Index

Note: Menu options appear under
their menu titles in boldface type.

About... DeluxePaint IV 222, 270
Action buttons 6, 209, 210
Activation point 31
Active line 30
Add Frame 237
Again rule 98, 208
Airbrush tool 31-32, 36, 55, 56,
196
Amiga Display modes 282-287
Angle step 111
Anim Menu 230-240
AnimBrush 230-231
Load 232
Save 233
Move 233-236
Frames 236-237
Control 237-239
Method 239-240; see also
Compressed and Expanded
Animation 8
basic model 127
commands 277
cyclic 137-139
effects 161-180; receding or
approaching shapes 161-
162, dissolve 162-163,
expanding circles 163-164,
trails 164-165, curving
titles 166-167, tumbling 3D
objects 167-169, spinning
174-180
frames 65
keyboard equivalents in 63
painting with 131-132
recording 154
Animation Control Panel 129-
130
commands 277
AnimBrush 65
creating an 144
flip an 225
metamorphose (transform)
147-148
picking up an 145
painting with an 145
settings 145-147
Animfill 191
Animpainting 64-66, 131-132
AntiAlias 9, 256-257
Assigns button 210
AutoGrid 265

289

AutoTransp 45, 265
Axes 154-155
rotation on brush 156-157, 267

Background 171
fixing the 63-64, 99
scrolling the 171-172
Background color 18, 206
default 25
erasing to the 26
painting with the 25-26
transparent 46
Background>Fix 64, 180, 256
Background>Free 64, 256
Background>Lock FG 256
Be Square 32, 196, 264
Bg->Fg 250
Bg<->Fg 251
Bit plane 271, 282-283
Blend 229
Brush 28
affected by a stencil 98
anything can be a 34-35
axes 154-155
built-in 28, 55, 186
commands 273
coordinates 112-115
creating a rectangular 44
creating an irregularly shaped
44-45
custom 44-49
display dependent on
memory 110
duplicating a 45
enlarge or reduce 28
handle 48, 111-112, 169-171
in Perspective mode 48
is a little picture 47-48
moving a 45
moving in 3 dimensions 133
painting modes 60-62
polygonal 200
rotating in 3D space 107-108
Brush Menu 223-227
Load 223
Save 223
Restore 223
Spare 223-224
Size 224
Flip 225
Edge 225-226
Rotate 226
Bend 226
Handle 227

Index

Brush mode, painting 266

Brush Selector tool 34-35, 57,
199-200

Brush<->Spare 223

Brush>Spare 223

Built-in brushes 28, 55, 186

Cels 65, 230
Chip RAM 102
Circle tool 33, 197
CLR 206
Color
background 18, 206
changing 36, 93-94 (HAM)
controls 276
copy 71-72, 245
creating a new 247
delete 246
exchange 71-72, 246
foreground 18, 206
lock 96-98
mask 96
mixing 78, 248
modifying 245
pick 27, 246
processing options 94-95
screen format and 219
selecting a 247
spread 72, 246
transparent 35, 45, 265
working with 69-77
Color (Mode) 60, 61, 228
Color Cycling 10, 53
with ranges 85-88
Color Indicator 18, 25, 206, HAM
207
Color Menu 240-252
Ranges 242-243
Cycle 243
Palette 243-249
Color Set 249-250
BG->FG 250
BG<->FG 251
Remap 251
Recompute 251
Brush 251-252
Color Mixer 8-9, 52-53, 70-77,
207, 244-247
Color register 86, 220, 282, 285
Color Set 70, 72-73, 89, 249
loading and saving 74, 79, 250
ColorText 15, 57
Color Wheel 76
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Compressed memory method
132,171, 240, 271

Constrain the cursor 139
a tool 186

Continuous Freehand tool 29, 36,
187-188

Control 237-238

Coords 121, 263-264, 267

Copy to spare 216

Curve 55

Curve tool 30-31, 190

Custom brushes 44-49

Cycle 61, 229, 243

Default palette 249
Default settings 17
Delete 213
Delete Frame 237
Delete this Page 216
DeluxePaint 111 1, 69
DeluxePaint IV, screen 49-50
DeluxePaint IV
About... 222, 270
default settings 17
hardware requirements 14
hintsand reminders while
using 4
installing to hard disk 15-16
manual 2
quitting 19
software 13
starting 17-18
using with floppy drive 16-17
what’s new in 7-10
Directional gradients 83
Disks
button 209
organizing 14
copying 14
Dither 195, 242
pattern and random 81-82
Dotted Freehand tool 29, 36, 186
Double 225

Ease In/Ease Out 140-141, 180-
181, 235

Edge 225

Edit box 7, 39

Effect Menu 252-262
Stencil 252-255
LightTable 255-256
Background 256
AntiAlias 256
Process 257-258
Translucency 258-259
Perspective 259-262

Ellipse tool 33, 198

Euler angles 112

ExclBrush 264

Expanded memory method 132,
240, 271

Extra-Halfbrite 62, 218, 284

Eyedropper 73

FastAdjust 92, 266
FastFB 49, 264
Fill tool 31, 190-191

Fill Type requester 82-85, 191-195

Filled Freehand Shape tool 187-
188
Fine Tuning 104
Fixing the background 63-64, 99
Flip 215, 225
FONTS 201-203
Foreground color 18, 206
Frame slider 129
Frames 236-237
Frames 230
creating 128
painting on 128-129
merging with LightTable
152-153
Freehand Shape tool 29-30
Fringing 92-93, 221, 287

Go Back 135-136

Gradient fills 53, 82-85, 193-195
linear 83-84
radial 84-85

Grid tool 36, 58-59, 203

Halve 225
HAM (Hold and Modify) 7-8,
219-221, 284, 285-287

animation with 149
changing colors in 93-94
fringing 92-93, 221, 287
outlining in 225
painting in 89-95
palette 89-90
ramping 90-91, 287

Handle 227

HBRITE 229-230

Hi-Res 54, 218-219

High resolution 283

HSV
color system 52, 74-78, 245
sliders 71

Hue 75-76, 245

Hue 258

Hybrid cycles 88

Installing DPaint IV 15-16
Interlace 54, 218
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Jaggies 9, 180

Key positions 149
Keyboard equivalents 27, 63,

273-277

LightTable 8, 149-151, 255-256
Linear fills 83

gradients 83-84, 193-194

Load. See individual menus
Load requester 38-39
Loading a file 18-19, 211
Lo-Res 54, 218

Low resolution 282

Magnify tool 37, 205
Matte 60, 61, 228
Med-Res 54, 218
Memory

affects painting 110
availability 267, 270
fragmentation 272
management 270-272
Menu 24, 208
submenu 208
Menu Bar 18, 24-25
Merge in Back 216

Merge in Front 216

Metamorph 224
Metamorphosis 8, 147-148
Method 239-240
Mixing area 73, 247
Mode Menu 228-230

Matte 228

Color 228

Replace 228

Smear 228

Shade 228-229

Blend 229

Cycle 229

Smooth 229

Mix 229

HBrite 229-230
Modifying tools 55-59
Mouse 5

painting with 5
Move 233-236
Move requester 132-133, 141-144,

233-236
MultiCycle 61, 229, 264

No Icons 265
NTSC monitor 221
Numeric keypad 109

OriginUL 266
Outline 225
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Overscan 217, 221, 272

Page 17,49
scrolling the 51
switching 50
Page Size 50-51, 216-217
Painting modes 60-62, 266
Painting screen 23-24
PAL monitor 221
Palette 243-249
Palette 18, 25, 52-54, 207
arrange 53, 74, 248
common 211
default 249
HAM 89-90
load and save 74, 249
manipulating 69-77
restore 249
screen formats and 54
spare page 50
use brush 248-249
Palette Mixer. See Color Mixer
Pattern edit field 209
Perspective 107-124, 259-262
commands 276
Picture Menu 208-223
Load 209-211
Save 211-212
Delete 213
Print 213-215
Flip 215
Spare 215-216
Page Size 216-217
Show Page 217
Screen Format 217-222
About 222
Quit 223
Pixel 28, 32, 56
Player utility 278-281
Polygon tool 34, 198-199
Prefs Menu 263-266; customizing
the Prefs menu 263
Coords 263-264
FastFB 264
MultiCycle 264
Be Square 32, 196, 264
Workbench 264
ExclBrush 264-265
AutoTransp 265
No Icons 265
AutoGrid 265
OriginUL 266
FastAdjust 266
Print 213-215
Process 95, 257-258

291

Quitting DeluxePaint 19, 223

Radial gradients 84-85, 194-195
RAM (Random Access Memory)
15,17
Ramping 90-91, 220-221, 225, 287
Random 242
Range 61, 242-243
building the 80-81
color cycling 85-88
copy a 242
defining 53-54
working with 78-88
ReadMe file 13
Recompute 92, 93
Recompute 251
Rectangle tool 32, 196
Remap 251
Replace 228
Requester 5-6, 209
Restore Palette 249
RGB
color system 52, 74-78, 245,
282-283, 286-287
sliders 71
Rotate 226
Rotation 134
displayed in Title Bar 114

Saturation 75, 245

Save. See individual menus

Saving a file 38-39, 51

Scratch page 49-50

Screen axes 154-155

Screen coordinates 112-115

Screen Format 52, 217-219, 272
palettes and 54

Screen resolution 51-52, 282-283

Scroll bar 6

Scroll box 19

Scrolling background 171-172

Shade 228-229

Shear 226

Shift key 186

Show Page 51, 217

Size 224

Smear 60, 228

Smooth 60, 229

Spacing requester 56, 182, 188-
189

Spare page 44, 49-50, 215-216
Spare>Metamorph 148
Special commands 275
Spreads, creating 53

Squares 32

Starting DeluxePaint [V 17-18

Index

Startup-sequence 15-16
Stencil 96-104, 252-255
fine tuning 104
in HAM 102-104
memory and 271
painting a 100-101
Stencil>Paint 10
Straight Line tool 30, 55, 188
Stretch 224
Submenu 208
Swap 215
Symmetry too! 36, 58-59, 204-205

Technical support 20

Text tool 35-36, 57, 200-202

Tint 257

Title Bar 18, 24
displays rotation angles 114
hiding 49
user feedback in 266-267

Tolerance 10, 103

Tools
constraining 186
modifying 55-59

Toolbox 17-18, 28-38, 50, 185-208
commands for the 274
hiding the 49

Traces 188

Translucency 92, 94, 258-259

Transparent color 35, 45, 265
changing the 46-47

Trim 226

Tweening 149-151

UNDO 26, 206

Unfilled shape tools 55-56
Unit 217

Use Brush Palette 249
Value 75-76, 245, 258

Wire frame 134
Workbench 264

Wrap

Zoom tool 37, 205
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Artist Bios

Lee Taran

Dan Silva

When Lee entered Stanford University, she was an aspiring
young artist. Oil painting had been her first love at Manhattan’s
famed School of Music and Art, and college might have been a
pleasant diversion before entering the New York “Art Scene.”
At the prodding of some friends, she took a computer science
course “for the fun of it.”

Like many of the creative talents who have worked with Elec-
tronic Arts, Lee’s entry into big-time programming began inno-
cently enough with the Amiga. It's a familiar story: The Amiga
was released, it was neat, it was fun, it had color, and suddenly
— note the slightly crazed look of excitement typical in these
cases — “I've got to program this thing!” Lee was hooked.

The art world became a sweet memory. Because Stanford had no
undergraduate major in computer science, Lee designed a major
for herself in Al, and took all the systems and computer science
courses the university had to offer. She then took time away from
school to get some graphics expereince, and wound up working
at EA on some of Dan Silva’s old code. Following six months

of intensive hacking on the EGA /VGA support for the Prism
graphics primitives, she returned to Stanford for her degree, and
stayed on for an M.S. in Computer Systems.

Through all her training and diverse experience, computer
graphics has remained an enduring passion. Her belief that high-
quality artwork can be created with a computer led her back to
Electronic Arts, and has resulted in DeluxePaint IV. And she
won't stop there.

When she’s away from the keyboard, Lee’s a discriminating sci-fi
fan, a connoisseur of trashy TV, and a dedicated aerobics/work-
out freak. She and her husband Ali share their home in Palo Alto,
Calitornia with two big cats named Dido and Zack.

Dan Silva is a legend. By the time Dan joined Electronic Arts in
1983, he had already worked with computers and computer
graphics for twenty years. In productive stints at Informatics,
Xerox, and Lucasfilm, he had designed a video editor, and new
generation bitmap editor, and written an interactive language for
displaying equations as graphic images. As important as his
achievments was the fact that his work helped him form a clear
idea of how the ideal paint program should behave.













PROGRAM LICENSE AGREEMENT AND LIMITED WARRANTY

Carefully read all the terms and conditions of this agreement prior to using the enclosed diskette. Your use of the
diskette indicates your acceptance of these terms and conditions.

If you do not agree to these terms and conditions, you may obtain a full refund by returning the unopened diskette
package and the other components of this product along with your receipt to the Commodore dealer where the
purchase was made within three (3) days following such purchase.

1. Copyright: These programs and the related documentation are copyrighted. You may not use, copy, modify,
or transfer the programs or documentation, or any copy except as expressly provided in this Agreement.

2. License: You have the non-exclusive right to use any enclosed program only on a single computer. You may
load the program into your computer’s temporary memory (RAM). You may physically transfer the program from
one computer to another provided that the program is used on only one computer at a time. You may not
electronically transfer the program from one computer to another over a network. You may not distribute copies
of the program or accompanying documentation to others. You may not decompile, disassemble, reverse
engineer, modify or translate the program or documentation. You may not attempt to unlock or bypass any copy
protection utilized with the program. All other rights and uses not specifically granted in this license are reserved
by Commodore.

3. Back-up and Transfer: You may make one (1) copy of the program solely for back-up purposes. You must
reproduce and include the copyright notice on the back-up copy. You may transfer and license the product to
another party only if the other party agrees to the terms and conditions of this Agreement and completes and returns
a registration card to Commodore. If you transfer the program you must at the same time transfer the
documentation and back-up copy or transfer the documentation and destroy the back-up copy.

4. Terms: This license is effective until terminated. You may terminate it by destroying the program and
documentation and all copies thereof. This license will also terminate if you fail to comply with any term or condition
of this Agreement. You agree upon such termination to destroy all copies of the program and documentation.

5. Program Disclaimer: The programs are provided “as is” without Warranty of any kind, either expressed or
implied, including, but not limited to, the implied warranties of merchantability and fitness for a particular purpose.
The entire risk as to the results and performance of any program is assumed by you. Should the program prove
defective, you (and not Commodore or its dealers) assume the entire cost of all necessary servicing, repair or
correction. Further, Commodore does not warrant, guarantee or make any representations regarding the use of,
or the results of the use of, the program in terms of corrections, accuracy, reliability, currentness, or otherwise: and
you rely on the program and resuits solely at your own risk.

6. Diskette Limited Warranty: Commodore warrants to the original licensee that the diskette(s) on which the
program is recorded shall be free from defects in material and workmanship only for a period of ninety (90) days
from the date of original purchase. If a defect covered by this warranty occurs during this 90-day warranty period,
and itis returned to the dealer from whom it was purchased not later than five (5) days of the end of such 90-day
period, the dealer shall, at the dealer’s option, either repair or replace the diskette.

The above warranty is exclusive and in lieu of all other warranties, express or implied (other than those warranties
implied by state law). All state statutory implied warranties, including, but not limited to implied warranties of
merchantability or fitness for a particular purpose shall be limited to a period of 90 days from the date of your original
purchase. No warranties, either express or implied, will apply after this period.

7. Limitation of Liability: Commodore’s liability is limited solely to the repair or replacement of the defective
product, inits sole discretion, and shall notin any eventinclude damages for loss of use or loss of anticipated profits
or benefits or other incidental or consequential costs, expenses or damages, including without limitation any data
or information which may be lost or rendered inaccurate, even if Commodore has been advised of the possibility
of such damages.

Some states do not allow a limitation on how long an implied warranty lasts, or limitation of incidental or
consequential damages, so the above limitations or exclusions may not apply 1o you. This warranty gives you
specific legal rights, and you may also have other rights which vary from state to state.

8. Miscellaneous: This Agreement represents the entire understanding regarding the programs and related
documentation, and supersedes any prior purchase order, communications, or representations. This Agreement
may only be modified by a written amendment signed by an officer of Commodore. If any provision of the
Agreement shall be deemed unlawful, void, or for any reason, unenforceable it shall be deemed severable from,
and shall in no way effect the validity and enforceability of the remaining provisions of the Agreement.

This license Agreement shall be governed by the laws of the United States of America, Commonwealth of
Pennsylvania.

9.The program License Agreement shall inure to the benefitof Commodore-Amiga, Inc., its parent, and all affiliated
companies thereof.
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